Author Topic: "Saving Samba module" is too slow with a huge number of files  (Read 2724 times)

fmartin

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
"Saving Samba module" is too slow with a huge number of files
« on: October 02, 2013, 05:16:03 pm »
I have a share with a few GB and about 1.5 million of files. When I do a change (like gateway configuration) in Zentyal and I do "Save Changes" I need wait about two hours while the operation "Saving samba module". With less files I need to wait less time.

Any solution?

Thank you.

zworK

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: "Saving Samba module" is too slow with a huge number of files
« Reply #1 on: October 03, 2013, 10:44:47 am »
I noticed the same behavior, but I just have to wait 15 minutes ;)

Looking at the logs, it seems that samba is accessing all shared files, maybe an ACL check? I see lots and lots of "smbd_audit" line from 127.0.0.1.

During a configuration change, samba module restart or reboot, these 2 samba processes hogs the cpu:
/opt/samba4/sbin/smbd -D --option=server role check:inhibit=yes --foreground
/opt/samba4/sbin/smbd -D

Also iotop only shows "disk write"  and no "disk read" from:
/opt/samba4/sbin/smbd -D --option=server role check:inhibit=yes --foreground

I tried to find documentation about the "server role check:inhibit=yes" parameter, but searching the man pages and google gives no usefull result ...

I did not dig any deeper, maybe a strace of the samba process will show what is happening. Or someone with more samba4 knowledge will let us know :)

swsch

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: "Saving Samba module" is too slow with a huge number of files
« Reply #2 on: October 21, 2013, 02:18:07 pm »
I snooped around a bit and found that after changing some settings in /etc/zentyal/samba.conf the startup "problem" disappeared.
  • line 128: unmanaged_acls = yes
  • line 134: disable_fullaudit = yes

Be aware that I have no idea if running with unmanaged_acls = yes is good for your system, it might result in some weird errors that are nigh impossible to track down.

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 281
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: "Saving Samba module" is too slow with a huge number of files
« Reply #3 on: October 21, 2013, 08:10:55 pm »
any solution for this??

i have same problem
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 281
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: "Saving Samba module" is too slow with a huge number of files
« Reply #4 on: October 24, 2013, 10:28:32 pm »
I snooped around a bit and found that after changing some settings in /etc/zentyal/samba.conf the startup "problem" disappeared.
  • line 128: unmanaged_acls = yes
  • line 134: disable_fullaudit = yes

Be aware that I have no idea if running with unmanaged_acls = yes is good for your system, it might result in some weird errors that are nigh impossible to track down.

i tried this option

  • line 128: unmanaged_acls = yes

but samba dont work... the permissions in files s0x, and the "__USERS__" is deleted. DONT ACTIVE THIS OPTION.
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl