Author Topic: Configuration for OVH (gateway reachable only after adding explicit route to it)  (Read 8901 times)

gmarcon

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
I have a Zentyal VM hosted on OVH. With OVH, the IP assigned to the VM is typically completely unrelated to the actual network segment.
What it means is that for example with an IP 12.23.34.45 you will have a netmask of 255.255.255.255 and a gateway like 56.67.78.254.
The only way to configure this gateway is of course to let the route to it known by an explicit route of the kind route add 56.67.78.254 dev ethX.

The typical configuration file looks then like this:
iface eth0 inet static
        address 12.23.34.45
        netmask 255.255.255.255
        broadcast 12.23.34.45
        post-up route add 56.67.78.254 dev eth0
        post-up route add default gw 56.67.78.254                 
        post-down route del 56.67.78.254 dev eth0               
        post-down route del default gw 56.67.78.254



I found no way of configuring this in Zentyal, the only option seems to have a /etc/ebox/hooks/network.postsetconf hook that overwrite the generated /etc/network/interfaces with the correct /etc/network/interfaces file.

I found a previous topic in the forums with someone having the same problem but no other solution different from mine:
http://forum.zentyal.org/index.php?topic=5607.0

Someone has a neater solution in mind?

Thank you.

robb

  • Guest
What is OVH? Is that a VPS provider or something? I couldn't find anything else than that related with virtualisation.

If OVH is not providing a subnet that gives direct connection to internet, you should talk to them to let them explain how their network acts. Anyway, I wouldn't choose a provider that makes it such a problem to create a network connection.

I have a VPS with a provider myself and a direct connection to internet with a dedicated IP address.

I don't think this is Zentyal related, but in Zentyal you can configure ANY IP address you want for every NIC you have on your server.

I might not understand what is exactly your problem, but I find it rather strange that you have to add a static route if you want to reach a gateway.

MRit

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
I need assistance in this matter.
Did not get to organize the network when you restart.

How do I get started with parameters /etc/network/interfaces :
Code: [Select]
auto lo eth0 eth1

iface lo inet loopback

iface eth0 inet static
address 11.22.33.44
netmask 255.255.255.255
boadcast 11.22.33.44
post-up route add 161.81.77.254 dev eth0
post-up route add default gw 161.81.77.254
pre-down route del 161.81.77.254 dev eth0
pre-down route del default 161.81.77.254

iface eth1 inet static
      address 192.168.0.102
      netmask 255.255.255.0
      broadcast 192.168.0.255

dns-nameservers 213.186.33.99
dns-search mydomain.com

After the restart /etc/network/interfaces has the form:
Code: [Select]
auto lo eth1

iface lo inet loopback


iface eth1 inet static
      address 192.168.0.102
      netmask 255.255.255.0
      broadcast 192.168.0.255

afranca

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Any solution?

I'm having this same problem.
« Last Edit: June 02, 2023, 07:30:54 pm by afranca »

dzidek23

  • Zen Apprentice
  • *
  • Posts: 45
  • Karma: +1/-0
    • View Profile
Hi afranca,

If you edit default Linux config files, Zentyal will overwrite them on reboot.

Use Hooks and Stubs to create persistent configuration

please look at https://doc.zentyal.org/en/appendix-c.html#stubs and https://doc.zentyal.org/en/appendix-c.html#hooks

Cheerio

rubic

  • Zen Monk
  • **
  • Posts: 86
  • Karma: +12/-1
    • View Profile
I have a Zentyal VM hosted on OVH. With OVH, the IP assigned to the VM is typically completely unrelated to the actual network segment.
What it means is that for example with an IP 12.23.34.45 you will have a netmask of 255.255.255.255 and a gateway like 56.67.78.254.
The only way to configure this gateway is of course to let the route to it known by an explicit route of the kind route add 56.67.78.254 dev ethX.
Try to set ethX in DHCP mode. Nowadays it is common for vps hosters to use off-subnet gateways. They send classless static route to the gatewey via DHCP option 121.