Author Topic: RESOLVIDO - Antivirus Deixando Videos Stream Lento  (Read 3953 times)

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
RESOLVIDO - Antivirus Deixando Videos Stream Lento
« on: August 31, 2010, 01:48:05 pm »
Ola,

Ja sabemos que o antivirus deixa a conexao um tanto mais lenta que a normal e piora quando se visualiza videos ( ex: Youtube, Globo.com ).
Porem existe a possibilidade de criar uma whitelist com sites os quais o clamav nao irá scanear ou criar uma regra de exclusao por extensao de arquivos ( .flv .pdf , etc ).

Eu tentei inserir essas regras no clamd.conf e apos salvar e reiniciar o servico ele retorna para o arquivo original, porque isso?

Como posso criar essas alterações permanentes?

Obrigado
« Last Edit: August 31, 2010, 10:09:48 pm by marcelhalls »

andremedeiross

  • Zen Monk
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #1 on: August 31, 2010, 04:05:24 pm »
simples qualquer alteração que vc queira que fique permanente que sai do padrão do ebox vc faz no diretório

Quote
/usr/share/ebox/stubs/

no seu caso para alterar configurações do clamav vc alteraria em

Quote
/usr/share/ebox/stubs/antivirus/clamd.conf.mas

todos os scripts contidos la com o final ".mas" são scripts que o ebox administra e ficarão fixados ao reiniciar o ebox ou o sistema
-----------------------------------------------
Buscai ao Senhor enquanto se pode achar,
invocai-o enquanto está perto.
-----------------------------------------------

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #2 on: August 31, 2010, 05:05:35 pm »
simples qualquer alteração que vc queira que fique permanente que sai do padrão do ebox vc faz no diretório

Quote
/usr/share/ebox/stubs/

no seu caso para alterar configurações do clamav vc alteraria em

Quote
/usr/share/ebox/stubs/antivirus/clamd.conf.mas

todos os scripts contidos la com o final ".mas" são scripts que o ebox administra e ficarão fixados ao reiniciar o ebox ou o sistema


Andre,

Eu inseri as seguintes configurações no final do arquivo:


abort \.youtube\.com
abort .*\.(png|gif|jpg)$
abort ^.*\.(pdf|swf)$
abortcontent ^image\/.*$
abortcontent ^video\/x-flv$
abortcontent ^video\/mp4$
abortcontent ^.*application\/x-mms-framed.*$

Estou esperando o pessoal ir almocar para iniciar o servico de antivirus, senao as conexao serao dropadas e os downloads perdidos.

Jaja testo e respondo aqui.

Obrigado!


marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #3 on: August 31, 2010, 05:38:48 pm »
Nao deu certo!

Tentei colocar essas opcoes para livrar algumax extensoes do clamav e o youtube, mas nao foi possivel.

Qualquer sites que eu acesse ele nega dizendo que nao pode scannear o conteudo.

Comentei as regras e voltou ao normal.

Algum parametro que ficou errado? peguei essas informacoes em um tutorial do clamav.

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #4 on: August 31, 2010, 06:17:57 pm »
Tentei colocar tambem dento do freshclam.conf.mas  mas nao rola, o video demora demais para iniciar.


o engracado agora é que quando eu pago o antivirus ( /etc/init.d/ebox antivirus stop ) eu nao navego mais!


Quem ja viu!

andremedeiross

  • Zen Monk
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #5 on: August 31, 2010, 06:35:42 pm »
na verdade para trabalhar sem o antivirus vc tem que desabilitar no ebox no modulo http-proxy e depois salvar

mas deve ser que está inserido no local errado do script do antivirus clamd.conf.mas, o freshclam.conf.mas é somente para atualização do banco de dados de virus.

o estranho é que eu tenho um servidor que é liberado o youtube para todo mundo tem 86 estações penduradas no servidor e não demora não, meu link é de 8mb e está nomal, rapidinho

o servidor arrasta um pouco para acessar o ebox pois é um P4 com 2GB de ram e 400 gb de discos, mas aqui tudo funciona e com o clamav ativo

-----------------

ah e vc pode desabilitar as estenções que quer la no http-proxy tbm
pelo próprio ebox

vai em Perfis de filtros

e configura o perfil default
aceitando as extensoes que vc quer que ele não filtre, vc pode adicionar novas extensões tbm
tenta la que acho q funciona

no perfil default tbm adiciona os dominios que vc quer liberar que não passem por filtro deixa na opção aways allow

por exemplo vc adiciona o dominio youtube.com e deixa ele com always allow vai liberar ele para sempre até que vc modifique
« Last Edit: August 31, 2010, 06:44:55 pm by andremedeiross »
-----------------------------------------------
Buscai ao Senhor enquanto se pode achar,
invocai-o enquanto está perto.
-----------------------------------------------

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #6 on: August 31, 2010, 06:58:17 pm »
Andre,

Consegui!

No diretorio /etc/dansguardian/lists/contentscanners contem os arquivos de configuracao do sntivirus para squid.

Eu entrei nos arquivos e inserir os dominios os quais nao precisavam scanear e as extensoes dos arquivos.

Reiniciei os servicos e estao funcionando perfeitamente!

Valeu!

ps tentei colocar o post como resolvido mas nao consegui :(
« Last Edit: August 31, 2010, 07:00:27 pm by marcelhalls »

andremedeiross

  • Zen Monk
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile
Re: Antivirus
« Reply #7 on: August 31, 2010, 07:12:01 pm »
blza então, mas como eu disse não precisava nem de ir no modo texto era só configurar o filtro default em regras de domínios e salvar

--------
ps para colocar como resolvido é só ir na sua primeira mensagem e clicar em modify em cima do post depois mudar o título
« Last Edit: August 31, 2010, 07:13:42 pm by andremedeiross »
-----------------------------------------------
Buscai ao Senhor enquanto se pode achar,
invocai-o enquanto está perto.
-----------------------------------------------