Author Topic: Login into domain suddenly not possible anymore, but only from a single client  (Read 2327 times)

Zorus

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Greetings,

I´m managing an old system (server + a few clients for filesharing) of zentyal version 2 (i know...ancient, but it works^^)
Yesterday, one of the clients (they run windows 10) suddenly could not log in the domain anymore. I always got the message (german: Die vertrauensstellung zwischen dieser Arbeitsstation und der primären Domäne konnte nicht hergestellt werden)...in english "The trust relationship between this workstation and the primary domain could not be established"

after searching google it seemed to be an easy issue, but everything i tried from the search results didnt solve it. This included:
- resetting the password of the client
- changing the name of the PC client
- removing the client from the domain and join it back into it (multiple times)

whatever i do, the trust between the client and the domain cannot be regained. I can log into the profile just fine from other clients, its just this one that cannot do it anymore. I can join the domain with the client with no issues but i cant login with any profile afterwards.

Ideas to solve this would be very much appreciated!

Greetings from Germany
Zorus

turalyon

  • Zen Warrior
  • ***
  • Posts: 197
  • Karma: +15/-0
    • View Profile
Check the following link out. It seems you are affected by a bug in Samba.

- https://github.com/zentyal/zentyal/issues/2132



“This world is ours, and by the Holy Light we will keep it safe, now and forever".

Zorus

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
It was not the exact same update, because the client runs on Win10 not Win11, but deinstalling the latest update (KB5028166) fixed the issue!

So what now? Is there any info on whether or not this issues is going to be fixed? Is it going to be from the Windows-side, which would of course be the best for me, as i could continue with the windows-updates then.
If not, this would mean that I have to upgrade my server or setting it up from scratch. Is there a Guide on how to go from such an old Version as mine (2.x) to the most recent (7.x). Like can I set up everything on a new server and then just reimport the user-profiles and file-shares?

Any further help is much appreciated!
Greetings, Zorus

chris.holmes

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +4/-0
    • View Profile
I was having a SAMBA issue with that exact MS Patch for Win 10 and I'm running Zentyal 6.1.6 - See post https://forum.zentyal.org/index.php/topic,35602.0.html
Thank you for providing a solution to my issue that presented in a very different way.  :)