Author Topic: Zentyal 7.0 - install mariadb instead MSQL 8.0  (Read 358 times)

spst

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +3/-0
    • View Profile
Zentyal 7.0 - install mariadb instead MSQL 8.0
« on: May 19, 2021, 11:22:17 pm »
Hello,

unfortunately, in addition to Zentyal, I also run other database programs but it doesn't work with MySQL 8.0. My database program works well with mariadb or MySQL 5.x versions.

I tried to install Zentyal version 7.0 with mariadb but during installation it removed mariadb and installed version 8.0 of MySQL.

How can I install Zentyal version 7.0 with mariadb?

Could someone help me?

Thanks for the help.

turalyon

  • Zen Apprentice
  • *
  • Posts: 46
  • Karma: +11/-0
    • View Profile
Re: Zentyal 7.0 - install mariadb instead MSQL 8.0
« Reply #1 on: May 21, 2021, 05:36:14 pm »
Hi,

The package 'mysql-server' is a dependency of 'zentyal-core', so, those packages must be installed and configured, otherwise, your Zentyal server will be unstable.

Also, I don't think it is a good idea to install Mariadb in the same machine, did you consider Docker?


spst

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +3/-0
    • View Profile
Re: Zentyal 7.0 - install mariadb instead MSQL 8.0
« Reply #2 on: May 22, 2021, 07:19:20 pm »
Dear turalyon,

thanks for your advice but unfortunately this is not a solution for me.

I am running two virtual machines (FreePBX and Windows) under Zentyal and the server is no longer suitable for this task. Therefore, it would be a solution to replace mysql 8 with mariadb or mysql 5.7.

Unfortunately, I haven't been able to solve this under Zentyal 7 yet I'm looking for a solution.

Thanks for your help.