Author Topic: Zentyal 2.2.1 upgrade to 6.2  (Read 507 times)

igarcia

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Zentyal 2.2.1 upgrade to 6.2
« on: October 28, 2020, 04:51:03 pm »
Hi:

Is there a way to perform an automatic upgrade from Zentyal V-2.2 to Zentyal V-6.2?

I been trying to restore a backup from 2.2 into 6.2, I installed all the packages but i´m still receiving the message about missed packages into my new version.

"apache bwmonitor ebackup events ids l7-protocols monitor objects services trafficshaping usercorner users webserver"  need to be intalled before restore the backup

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Zentyal 2.2.1 upgrade to 6.2
« Reply #1 on: October 29, 2020, 09:57:35 am »
 :)

I didn't work with Zentyal version 2.x, but I have upgraded from Zentyal 4.x to Zentyal 6.x and the process consists of a gradual upgrade from version to version https://doc.zentyal.org/en/upgrade.html

Zentyal 2.x is a prehistoric beast and, as you can see in the link, it isn't included in the official documentation. I bet you'll have to make a fresh install.

The config backup from 2.2 to 6.2 isn't a good idea, check the changelogs from version to version.

Cheers!
« Last Edit: October 29, 2020, 09:59:21 am by doncamilo »
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

igarcia

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Zentyal 2.2.1 upgrade to 6.2
« Reply #2 on: October 29, 2020, 10:11:02 pm »
Thank you for your comments , I understand that I was trying to avoid all the re-configuration but now i´m working in a fresh installation.

regards