Author Topic: после обновления перестала работать админка и инет  (Read 3590 times)

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
не запускается веб интерфейс, где посмотреть настройки сети? поднять конфиг тоже не могу так как не работает админка,что теперь делать(

Sand_man

  • Zen Samurai
  • ****
  • Posts: 280
  • Karma: +24/-0
    • View Profile
До 3.3.5 обновлялся? Я на своём основном не рискнул, нарывался уже на неприятности раньше. А вот на один удалённый накинул обновление. Правда только системные обновления, компоненты zentyal-овские не стал. А в системных обновление самбы. Ну и тоже капец. Тьфу, хоть сервер пока не в работе был. Тоже доступа нет по ssh теперь. Завтра только посмотрю.

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
У меня доступ есть,хотя бы инет востановить(
admi@N:~$ service zentyal start
Cannot change user to ebox. Are you root? at /usr/share/perl5/EBox.pm line 174.

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
тойсть
Error loading class: EBox::Samba error: Bareword "Samba::Smb::DENY_NONE" not allowed while "strict subs" in use at /usr/share/perl5/EBox/Samba/SmbClient.pm line 89.
Compilation failed in require at /usr/share/perl5/EBox/Samba/GPO.pm line 28.
BEGIN failed--compilation aborted at /usr/share/perl5/EBox/Samba/GPO.pm line 28.
Compilation failed in require at /usr/share/perl5/EBox/Samba.pm line 42.
BEGIN failed--compilation aborted at /usr/share/perl5/EBox/Samba.pm line 42.
Compilation failed in require at (eval 271) line 2.
BEGIN failed--compilation aborted at (eval 271) line 2.

logdog

  • Zen Hero
  • *****
  • Posts: 623
  • Karma: +29/-2
    • View Profile
Решение, судя по багтрекеру, в том, чтоб проапгрейдить до 3.3.4 samba
sudo apt-get update
sudo apt-get upgrade

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
я сразу подумал что это должно помоч,но не работает
sudo apt-get update
sudo apt-get upgrade
у меня интернет через шлюз 10.10.0.1 работал, теперь не работает(система не видит днс сервер), только если с браузера с прописанной в нем проксей 10.10.0.1:3128
сама система инета не видет(

admi@N:~$ sudo apt-get update
Ош  http://ru.archive.ubuntu.com precise Release.gpg
  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»
Ош  http://archive.zentyal.org 3.3 Release.gpg
  Временная ошибка при попытке получить IP-адрес «archive.zentyal.org»
Ош  http://security.ubuntu.com precise-security Release.gpg
  Временная ошибка при попытке получить IP-адрес «security.ubuntu.com»
Ош  http://ru.archive.ubuntu.com precise-updates Release.gpg
  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»
Ош  http://ru.archive.ubuntu.com precise-backports Release.gpg
  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»
Чтение списков пакетов… Готово
W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/precise/Release.gpg  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»

W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/precise-updates/Release.gpg  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»

W: Не удалось получить http://ru.archive.ubuntu.com/ubuntu/dists/precise-backports/Release.gpg  Временная ошибка при попытке получить IP-адрес «ru.archive.ubuntu.com»

W: Не удалось получить http://archive.zentyal.org/zentyal/dists/3.3/Release.gpg  Временная ошибка при попытке получить IP-адрес «archive.zentyal.org»

W: Не удалось получить http://security.ubuntu.com/ubuntu/dists/precise-security/Release.gpg  Временная ошибка при попытке получить IP-адрес «security.ubuntu.com»

W: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
прописал прокси в /etc/apt/apt.conf.d/99proxy вроде пошел обновлятся,причем все пакеты,
« Last Edit: March 11, 2014, 01:01:36 pm by Anton »

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
УРА!!!все заработало 3.3.5 всем спасибо!!!,через веб морду не советую обновлятся
« Last Edit: March 11, 2014, 01:11:47 pm by Anton »

Sand_man

  • Zen Samurai
  • ****
  • Posts: 280
  • Karma: +24/-0
    • View Profile
На месте apt-get-ом обновил, больше ничего не трогая, всё заработало.

bubnov-pi

  • Zen Samurai
  • ****
  • Posts: 425
  • Karma: +27/-0
    • View Profile
Подтверждаю - при обновлении через вэб-админку процесс завис, перестал работать ftp, squid стал безумно тормозить (хотя в принципе работал), но ssh доступ остался; не перезагружаясь обновился через apt-get и перегрузился - всё работает нормально.

tsf

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
УРА!!!все заработало 3.3.5 всем спасибо!!!,через веб морду не советую обновлятся
Добрый день.
а как и что прописывать в этом файле?

Anton

  • Zen Apprentice
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Привет!,
Acquire::http::Proxy "http://login:pass@xxx.xxx.xxx.xxx:yyyy"