Author Topic: [SOLVED] Zentyal 2.2 and zarafaSharedStoreOnly doesn't work  (Read 3646 times)

Stenneman

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
[SOLVED] Zentyal 2.2 and zarafaSharedStoreOnly doesn't work
« on: August 10, 2011, 12:24:52 pm »
Hi all,
I have a problem with the zarafaSharedStoreOnly attribute. I miss it in de users module and when I manually insert it in the zarafa server.cfg file and in ldap it doesn't work. Can you please help me with this?

Gerard Stenveld
« Last Edit: August 16, 2011, 02:42:52 pm by Stenneman »

jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: Zentyal 2.2 and zarafaSharedStoreOnly doesn't work
« Reply #1 on: August 13, 2011, 05:30:51 pm »
After adding it, does stay on LDAP tree? Can you post the diff to your server.cfg file? Keep in mind that you will have to do a custom template for server.cfg.mas!

Stenneman

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Zentyal 2.2 and zarafaSharedStoreOnly doesn't work
« Reply #2 on: August 16, 2011, 02:03:56 pm »
Solved. Got it to work. I changed some files, first in /usr/share/zentyal/stubs/zarafa/server.cfg.mas I changed server_bind to 0.0.0.0 and in ldap.openldap.cfg.mas I changed ldap_nonactive_attribute from empty to zarafaSharedStoreOnly.
Then I changed /usr/share/perl5/EBox/ZarafaLdapUser.pm and /usr/share/zentyal/templates/zarafa/zarafa.mas (see attachments).
I also updated zarafa with the commercial 7.0.1 version as we have a 25 user license directly from Zarafa. And lo and behold, working.