Author Topic: New Zentyal 2.1-1 beta installer available!  (Read 6596 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
New Zentyal 2.1-1 beta installer available!
« on: May 12, 2011, 01:51:34 pm »
Hi fellow Zentyal users,

We're glad to announce the availability of a new Zentyal 2.1-1 installer including all the current development improvements for 2.2 and the first beta of the new IPsec module.

You can download the new installer for 32 and 64 bit architectures from our Beta Downloads page. You can also install the 2.1 packages on an existing Ubuntu Server 10.04 following the instructions at our Installation Guide.

Users who already have a 2.1 installation, don't need to use the installer, just make sure to upgrade to the latest versions of all the available packages.

Zentyal 2.1 is a development version based on Ubuntu 10.04.2 and it will become Zentyal 2.2 (next stable release) in September (2011). Until then we are going to frequently release new versions so you can help us testing the new features and improvements.

These are the most relevant changes included in this second beta:

- New IPsec module
- New Asterisk 1.8 integration
- New module selection page on the installer
- Allow to define IP ranges on objects
- Reorganization of menu entries
- Improved bug report system with automatic creation of tickets
- Lots of bugfixing and minor improvements

Please remember that 2.1 is a beta version and it is not intended for production environments. But if you have a spare testing server or a VM you can be one of the first users to test these changes and help us by reporting any problem you encounter or simply giving any feedback or ideas. There are less than two months of development left until the freeze period for Zentyal 2.2, so hurry up!
« Last Edit: May 12, 2011, 02:01:54 pm by J. A. Calvo »
Zentyal Server Lead Developer

vpetcu

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: New Zentyal 2.1-1 beta installer available!
« Reply #1 on: May 13, 2011, 04:20:04 pm »
I have 2 questions about the future version 2.2.

On my search around zentyal forums, I discovered 2 modules that I'm really interested.

1. Zentyal-desktop
2. ltsp module.

Are they going to make it in the 2.2 version ???


Thank you.
Vasilica Petcu

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: New Zentyal 2.1-1 beta installer available!
« Reply #2 on: May 13, 2011, 07:49:32 pm »
Hi vpetcu,

Zentyal Desktop is a separate product, like Zentyal Server or Zentyal AD Sync, it can be released separately as it is not bound to a specific Zentyal Server version. You will be able to use the currently available zentyal-desktop with Zentyal 2.2 without problem, but I suppose you are asking for a new version of it, and I'm afraid there is no date set for that.

Regarding the Thin Clients module (LTSP), it depends on the donations (on June 1st you'll have the answer):

http://trac.zentyal.org/wiki/Document/Development/Fundraising

Thanks for your interest.
Zentyal Server Lead Developer

thepcsamurai

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: New Zentyal 2.1-1 beta installer available!
« Reply #3 on: May 16, 2011, 07:42:43 am »
The 2.2 roadmap indicates support for google Apps. is this still applicable?

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: New Zentyal 2.1-1 beta installer available!
« Reply #4 on: May 17, 2011, 06:35:22 pm »
It is still on the roadmap at the moment, but anyway, if there were any change, it would be announced in this thread:

http://forum.zentyal.org/index.php/topic,6625
Zentyal Server Lead Developer

frankz

  • Zen Apprentice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: New Zentyal 2.1-1 beta installer available!
« Reply #5 on: May 19, 2011, 05:33:10 am »
Any word on support for Debian Squeeze.

We build debian servers and work with them all day and really like what you have going here.

What has to be done maybe I can do it. 

Frankz

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: New Zentyal 2.1-1 beta installer available!
« Reply #6 on: May 19, 2011, 11:09:14 am »
Hi Frankz,

Yes, we want to have packages for Debian in the future, and even for other non-debian distros. But we can't give you a date for this yet...

What needs to be done is just build the packages from the source code in our SVN repository and make them work (probably with some changes that we still don't know due to the different versions of the packages that Zentyal depends on).

If you are interested in contributing, just ask on the #zentyal IRC channel or the zentyal-devel mailing list.
Zentyal Server Lead Developer