Recent Posts

Pages: [1] 2 3 ... 10

We have updated the official documentation with the mentioned steps in my previous answer about the Antivirus module. Below you have the links.


Again, thank you for reporting the issues.

Best regards, Daniel Joven.
News and Announcements / Upgrade from Zentyal 7.1 to 8.0 is now available
« Last post by blorente on April 16, 2024, 08:41:13 pm »
Hi all,

The upgrade path from Zentyal Server Development 7.1 to 8.0 has been published now. When you upgrade the 'zentyal-core' package to its latest version, "Upgrade button" will appear on the Dashboard.

We would recommend you to follow this checklist to avoid issues:

* Make sure you don't have pending updates
* Back up your server and data before upgrading
* Make sure that there are no errors in the /var/log/zentyal/zentyal.log file
* Make sure that there is space available on the disk
* Make sure that the server is updated
* Make sure that there are no broken packages
* Make sure that there are no errors in the internal Samba database or in the MySQL databases
* Make sure that you have Internet connectivity
* Click on the Upgrade button on the Dashboard
* Make sure that the packages have been updated

The official documentation for Zentyal Server 8.0 will include more detailed instructions.

Looking forward to receiving your feedback and comments.

We are debugging the antivirus issue, we believe three things should be analyzed:

1. The server was not rebooted after the upgrade, so the directory /var/run/clamav does not belong to the owner clamav.
2. You have a persistent stub and because of that, the module’s configuration is old.
3. ClamAV databases are not updated. It requires sudo freshclam

Meanwhile, we do the required tests, you should try the following:

1. Update the internal database:
    sudo freshclam

2. Make sure the module is enabled through the Zentyal GUI.
3. Ensure the directory /var/run/clamav belongs to clamav as chapderprinz suggested.
    sudo chown -R clamav /var/run/clamav/

4. Restart the module through the CLI:
    sudo zs antivirus restart

If the issue persists, you can try to restart the service through Systemd and then, check the log files.

sudo systemctl restart clamav-daemon
sudo journalctl -u clamav-daemon

Log files:
- /var/log/zentyal/zentyal.log
- /var/log/syslog
- /var/log/clamav/clamav.log

Best regards, Daniel Joven.
Figured out what I needed to do.  I had to add as new, and use the same name as before, and that pulled in the config.  All is back to normal now. 
running the following and accepting defaults seems to do the trick:

dpkg-reconfigure clamav-daemon
Daniel Joven:
It install official Zentyal ISO :
- probably 5(...)->6(...)->7(...)->8 - problem with mysql and  and missing apt
- 7(...)->8 problem with missing apt, mysql ok
Same symptoms here for Antivirus - start from GUI, stops after about 30 secs

Exact same log entry

The following file does not exist in my system:

Hi Daniel,

i updated my zentyal today with zentyal-core 7.1.2 and zentyal-core 8.0.1. The update process worked fine.
After that i restarted the server and e_mail, fetchmail and antivirus stoped working. After deinstall and reinstall the antivirus and mailfilter componets e-mail and fetchmail works fine.
Antivirus does not work. After restart the antivirus it seems to work for about 30 seconds. then the service stops again.

var/log/clamav/clamav.log tells the following:

Fri Apr 12 17:27:17 2024 -> +++ Started at Fri Apr 12 17:27:17 2024
Fri Apr 12 17:27:17 2024 -> Received 0 file descriptor(s) from systemd.
Fri Apr 12 17:27:17 2024 -> clamd daemon 0.103.11 (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
Fri Apr 12 17:27:17 2024 -> Log file size limited to 4294967295 bytes.
Fri Apr 12 17:27:17 2024 -> Reading databases from /var/lib/clamav
Fri Apr 12 17:27:17 2024 -> Not loading PUA signatures.
Fri Apr 12 17:27:17 2024 -> Bytecode: Security mode set to "TrustSigned".
Fri Apr 12 17:27:27 2024 -> Loaded 8690518 signatures.
Fri Apr 12 17:27:30 2024 -> ERROR: LOCAL: Socket file /var/run/clamav/clamd.ctl could not be bound: Permission denied


Changed the owner of /var/run/clamav to user "clamav" and it works for me (drwxr-xr-x  2 clamav   root)

Installation and Upgrades / Re: Zentyal 8 breaks when trying to update packages
« Last post by trvaa on April 12, 2024, 04:36:36 pm »
Many thanks for this.

I can confirm that after using option 2 here (command line option):

this worked for me (7.1.2 to 8.0.1)

Small point for correction at some point - Splash screen on start-up still says Zentyal 7.0

We have released the packages:

- zentyal-core 7.1.2
- zentyal-core 8.0.1

Both packages correct the APT and Mysql issues.

In case you already upgraded your Zentyal server and have any issues, you can check the following link out:


Again, thank you for reporting the issues.

Best regards, Daniel Joven.
Pages: [1] 2 3 ... 10