Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - covex

Pages: [1]
1
Other modules / Re: Zentyal 7 DNS: QUERY REFUSED
« on: October 06, 2021, 08:55:35 am »
What you have exactly added to named.conf.local?

I have there among trusted sources localnets, the VPN range is on local tap interface, but queries from VPN are refused. The .mas has also
acl "internal-local-nets" {
% foreach my $net (@internalLocalNets) {
    <% $net %>;
% }
};

but I did not found a way to get a VPN ranges into "internalLocalNets" - not sure how zentyal distiguishes this. So you have added directly your VPN IP range somewhere?

Thanks

2
I have the same issue on 6.0 - my question however is - how to get all records of the DHCP and DNS synced at the first place.

samba-tool dns query ad.my.domain my.domain @ ALL

shows results that absolutely do not match the dhcpd.conf.

samba_dnsupdate --verbose --all-names

does nothing with dhcp client names... it only synces whats in /var/lib/samba/private/dns_update_list

 I can do that manually via samba-tool dns but it is very tedious even for few addresses.

Any ideas?

3
Directory and Authentication / Re: Avoid samba binding to a vlan interfaces
« on: December 10, 2020, 06:54:04 pm »
Thanks, I do not like to modify stubs - here is a method that should work: there is a /etc/zentyal/samba.conf with "listen" and "listen_external" directives.. so setting the vlans as "external" and  setting "listen_external=no" should work, not sure what else this means for zentyal behavior thou...  not sure how to use the "listen" as there also seems to be only "yes,no" - not sure what this is for setting listen to no would cause most of the zentyal functions to be useless right?


4
Directory and Authentication / Avoid samba binding to a vlan interfaces
« on: December 09, 2020, 10:57:26 am »
I've Zentyal 6 and I created a two vlans in the interfaces, however samba not binds to their IPs and is trying to use the for replays for requests that came on a primary IP. The best would be to avoid this. Is the
checkbox
 External (WAN) Check this if you are using Zentyal as a gateway and this interface is connected to your Internet router.

the way to achieve the samba to not to bind to those vlan IPs?

Thanks.

5
Other modules / How to sort the users in web UI?
« on: October 05, 2019, 02:55:10 pm »
Is there a way to show the users sorted according login user name or anything else in the Samba/Tree/Manage (i.e. Users and Computers) web UI? Is seems it is by defaul sorted according to Display name which is kidna weired and there is no obvious way how to change it.

6
The final notice - the Z5.0 seems to use the default redis installation and config - if failed during install clean the /var/lib/redis/ and copy there a DB dump from /var/lib/zentyal/dump.rdb chown redis:redis and you are good to go.

7
What helped to me now - hard reboot, after upgrade to systemd formal upstart system, the system can not reboot thru systemd.

After that I remove the requirepass directive in /var/lib/zentyal/conf/redis.conf otherwise I got:
Code: [Select]
dpkg --configure zentyal-core
Setting up zentyal-core (5.0.14) ...
Reconnecting to redis server (1 try)... at /usr/share/perl5/EBox/Config/Redis.pm line 476.
Reconnecting to redis server (2 try)... at /usr/share/perl5/EBox/Config/Redis.pm line 476.
Reconnecting to redis server (3 try)... at /usr/share/perl5/EBox/Config/Redis.pm line 476.
Reconnecting to redis server (4 try)... at /usr/share/perl5/EBox/Config/Redis.pm line 476.
Redis command 'get version' failed: [get] NOAUTH Authentication required.,  at /usr/share/perl5/EBox/Config/Redis.pm line 453.
dpkg: error processing package zentyal-core (--configure):
 subprocess installed post-installation script returned error exit status 29
Errors were encountered while processing:
 zentyal-core

manually started redis with the zentyal config and re configured dpkg... it complained about upstart, but at least moved on:
Code: [Select]
dpkg --configure zentyal-core
Setting up zentyal-core (5.0.14) ...
Synchronizing state of zentyal.service with SysV init with /lib/systemd/systemd-sysv-install...
Executing /lib/systemd/systemd-sysv-install enable zentyal
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
insserv: warning: script 'lxdm' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `lxdm'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `lxdm'
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
insserv: warning: script 'lxdm' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `lxdm'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `lxdm'
Processing triggers for zentyal-core (5.0.14) ...
 * Restarting Zentyal module: webadmin                                   [ OK ]
 * Restarting Zentyal module: logs                                       [ OK ]

then you have to manually stop services like bind, samba etc. that were started by systemd at boot to continue with reconfiguration of packages... but still not there to start everything OK.... TBC.

Good luck.

8
Even thou this is old topic, I have the same problem. I did a test install of 3.5 and tried if I am able to upgrade to later version. 4.0 was fine, but during upgrade to 5.0 from web interface if ended with Zentyal upgrade failed. The problem is that zentyal-core is not properly configured at time when the package is installed. It fails to reach redis. As far as I can tell, this is a problem related to conversion to systemd. During redis installation the redis is started by the unit "consumes" the port 6379  or something and zentyal starts the redis on 6380, but the core package update is not able to use the redis on different port, at least I saw several times the redis started at 6380. Even thou I changed it to 6379 and disabled the unit and started it manualy the zentyal-core is not able to finish the reconfiguration.  The next problem seems authentication - zentyal-core is probably not able to authenticated to redis during install.
Code: [Select]
ebox.redis stop/waiting
Stopping redis-server: redis-server.
cp: cannot create regular file ‘/var/lib/redis/dump.rdb’: No such device or address
Starting redis-server: redis-server.
 * Stopping Zentyal module: printers
   ...done.
mv: cannot stat ‘/etc/zentyal/stubs’: No such file or directory

Upgrading from Ubuntu 14.04 to 16.04 with Zentyal 5.0...
Preparing to unpack .../redis-server_2%3a3.0.6-1ubuntu0.4_amd64.deb ...
/usr/sbin/invoke-rc.d: 1: /usr/sbin/invoke-rc.d: /sbin/runlevel: not found
invoke-rc.d: could not determine current runlevel
Stopping redis-server: redis-server.
Unpacking redis-server (2:3.0.6-1ubuntu0.4) over (2:2.8.4-2ubuntu0.2) ...
dpkg: warning: unable to delete old directory '/var/log/redis': Directory not empty
dpkg: warning: unable to delete old directory '/var/lib/redis': Directory not empty

Setting up zentyal-core (5.0.14) ...
Installing new version of config file /etc/cron.daily/zentyal ...
Installing new version of config file /etc/logrotate.d/zentyal-core ...

Configuration file '/etc/zentyal/core.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
 ==> Keeping old config file as default.

Configuration file '/etc/zentyal/hooks/template.postsetconf'
 ==> Deleted (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
 ==> Keeping old config file as default.
Installing new version of config file /etc/zentyal/zentyal.conf ...
Could not connect to Redis server at 127.0.0.1:6379: Connection refused at /usr/share/perl5/EBox/Config/Redis.pm line 511.
dpkg: error processing package zentyal-core (--configure):
 subprocess installed post-installation script returned error exit status 111


Whatever is causing this is preveting the smooth 4.x->5.x upgrade.  I tried to start the redis server manually same way as it was started at 4.0 (sudo -u ebox redis-server /var/lib/zentyal/conf/redis.conf) but the dpkg --configure -a is stuck forever, the zentyal GUI is unreachable as it is not configured/working.

9
Installation and Upgrades / Re: Interval for sending a service alert
« on: February 27, 2015, 05:08:06 pm »
I've found
SCANNING_INTERVAL = 60
EVENT_FOLDING_INTERVAL = 30 * 60
in EventDaemon.pm hardcoded.

I am just surprised zentyal is sending me a mail every 60s but it looks like it should send it every 30minutes but check every 60s.

10
Installation and Upgrades / Interval for sending a service alert
« on: February 27, 2015, 03:03:56 pm »
Is it somewhere possible to set an interval in which is Zentyal checking the events and sending alerts? Mainly checking its own services as it seems it checks it every minute, generating an email every minute when something is wrong. This merely causes s DoS on mailbox...

12
Yes I do have the same problem... did not found a way to delete a share created via group...

13
For Zentyal 3.5 I used LiLi to "unpack" the ISO to USB and then "well known" workaround with mount of iso copied on the USB to "mimic" the cdrom. http://www.marook-online.de/index.php?topic=106.0

For 4.0 this does not work and I did not found whatn the installer is looking for that it is refusing to mount cdrom.

Is there any other way to make the bootable USB for the installation that works?

Pages: [1]