Recent Posts

Pages: [1] 2 3 ... 10
1
Have been experiencing an issue where a Windows 11 Thunderbird client (115.12.0 (64-bit)) won't display CalDav calendar items from a user's SOGo email account or new items made in Thunderbird - but the new items made in Thunderbird are shown in the SOGo Webmail interface.

Wondering if this is related to the known issue in SOGo 5.5.1 where it adds in XML.  Anyone else experiencing this and is there a planned update to SOGo or is there a way to manually update via cli?

https://talk.plesk.com/threads/sogo-caldav-not-working-with-thunderbird-nor-outlookcaldavsynchronizer.371597/

"There where some changes in the gnustep-base 1.28.0 package that made SOGo add "& #65279" (without the "") to the calendar XML data.
SOGo fixed that bug in Version 5.8 but Ubuntu 22.04 is still using 5.5.1."

and

https://bugs.sogo.nu/view.php?id=5416

Sorry if this topic is covered elsewhere - nothing hit when I searched.
2
Other modules / Are there any GPO limitations with zentyal
« Last post by nanak on June 09, 2024, 01:58:21 pm »
I have been looking forward to migrate to zentyal for my business. I have one question. Are there any group policy limitations while using zentyal compared to windows server.
3
hola

Ya puede de nuevo sincronizar los dos zentyal,  el secundario al primario usando samba-tool en los dos server
principalmente este comando samba-tool dns update <server> <zone> <name> <A|AAAA|PTR|CNAME|NS|MX|SOA|SRV|TXT> <olddata> <newdata> con este cambie la ip nueva por la vieja
pero no se porque cuando por GUI se hace el cambio de las ip no las registra adecuadamente.
gracias por la pista
4
Manually deleting entries does not solve the problem. File /etc/netplan/netplan.yaml is created from information stored somewhere else and that is where it needs to be removed.
5
Spanish / Zentyal 8 + Docker
« Last post by joseag on June 05, 2024, 06:41:06 pm »
Hola a tod@s

Se que el módulo de Docker/Portainer está en beta, pero considero que tiene mucho potencial. Está genial que la gente de Zentyal le hayan hecho un hueco en el servidor, sin el problema de instalar Docker de manera independiente y atenerte a las consecuencias. No sé si alguien ha estado trasteando con él, yo sí. Abro este hilo para intercambiar experiencias.

Concretamente, lo he utilizado para instalar OCS inventory en el controlador de dominio, con un contenedor para MariaDB y otro para el propio servidor OCS + Nginx. Estuve haciendo pruebas en un servidor virtualizado y al final lo he instalado en el pro.

Alguna experiencia al respecto?

Saludos!
6
ok probare, y te comentare gracias
7
Buenas,

Lo más correcto para cambiar la IP hubiera sido deshabilitando el módulo de DNS antes de cambiar la IP y de cambiar los registros en el DNS. Una vez modificados, volver a habilitarlo.

Para comprobar si samba está escuchando por la IP deseada puedes usar el siguiente comando:

Code: [Select]

sudo ss -tunpl | grep ':389'


Y para asegurarte que los registros del DNS se han actualizado puedes consultar a la base de datos de samba:

Code: [Select]

sudo samba-tool dns query 127.0.0.1 <tu-dominio.com> @ ALL -U <tu administrator del dominion>


En caso de que no se hayan actualizado los registros, puedes forzar la actualización reiniciando samba:

Code: [Select]

sudo zs samba restart


O incluso puedes intentar deshabilitar el módulo DNS, guardar los cambios y volver a habilitarlo.

Si a pesar de todo lo anterior no te funciona, tendrás que realizar las modificaciones con samba-tool dns update como se explica en el siguiente enlace.

- https://wiki.samba.org/index.php/DNS_Administration#Updating_existing_records

Saludos.
8
Where is this info stored so that I can remove the virtual interfaces???

The network configuration is in /etc/netplan/netplan.yaml. The virtual interfaces entries are like this:

Code: [Select]
eth0.eth02:
      dhcp4: false
      dhcp6: false
      match:
        name: eth0.eth02
      set-name: eth0.eth02
      addresses:
        - 10.1.10.1/24
#            label: "eth0:eth02"

Those kinds of entries must be removed manually. After that, you must restart the network module:

Code: [Select]
sudo zs network restart
9
hola

Tenia dos zentyal sincronizados uno primario y el otro secundario , pero tuve que cambiar la ip del primario y le puse la nueva  ip de sincronización en el secundario , y me asegure que en el secundario y primario respondan por dns a la nueva ip y lo hacen .
cuando intento sincronizar en el secundario  " IP del servidor DNS del dominio " en la sección dominio me da error que no puede conectar porque manteniente la ip anterior o ip que no existe
"el controlador de dominio especificado 192.168.155.250 no es alcanzable"
alguna forma de decirle al dns o samba que tome la nueva ip ?
pd :los zentyal son version 8.0.3
gracias y saludos

10
Dear All!

This is my first post on this forum. I registered to share an experience with you, maybe it will be useful for someone else.

Last weekend I moved and upgraded a Zentyal system for one of our customers. The original VM was on VMware ESXi 6.5 and the new server runs Proxmox 8. The original Zentyal system was on 5.0.14...

I moved the VM with ovftool to the new server, comverted with qm importovf. First experinece is that the VM boots up but no console ouptut at all on the Proxmox virtual console. The sulution was editing the boot line in grub at boot time, removing "quiet splash..." from the linux line. Then the console showed up.

After configuring the newtork (of course, Ethernet adapter name differs on Proxmox), I realised that I need to configure the network on the web admin. Only manually configuring it in /etc/network/interfaces lost at reboot. After this, the gateway must be deleted and added again (to replace the interface name), also on the web admin.

After correcting the network and gateway, the upgrades from 5.0.14 to 6.0 -> 6.1 -> 6.2 -> 7.0 -> 7.1 went basically flawlessly to my surprise. I did everything by the book (a.k.a Zentyal 8.0 version upgrade page), so I checked all the things between every upgrade and rebooted the VM after each, then checked the services after each reboot.

Somewhere in the upgrades, some services (like mysql) got disabled, and because of this not started at boot. But this shows up relatively quickly, and enablig, starting sthose solve these problems.

After upgrading from 7.1 to 8.0, basically everything worked, but SOGo and antivirus modules. The antivirus module was easy, the /etc/systemd/system/clamav-daemon.service.d/extend.conf file was renamed on an upgrade, and /run/clamav folder was not created and configured for clamav daemon. After renaming back and restarting clamav-daemon and antivirus module, the service worked as expected.

The SOGo thing was much harder. The login screen showed up as plain text, without formatting and without any buttons, etc. No css, js, images get downloaded from the server. The SOGo system is a black box, very hard to debug what happens (or not happens). I searched the internet for hours at dawn to finally figure out that the SOGo version 5.0 which was used in Zentyal 5.0 to 7.1 has the necessary css/img/js/fonts files in /usr/lib/GNUstep/SOGo/WebServerResources but SOGo version 5.5.1 (which came with Ubuntu 22.04/Zentyal 8.0) put these files in /usr/share/GNUstep/SOGo/WebServerResources. Maybe this causes the problem.
To test this theory, I simply symlinked all 4 folders to the "old" place, restared sogo service and everything started working again!

I don't know why this happened. I archived all upgrade console messages on all upgrades and found noting erronous about SOGo upgrades in these logs. I found nothing about this folder change on the internet, found none occurence of this problem documented (yet). But maybe someone out there experience the same in the future when upgrading to Zentyal 8, and this is a solution for it.

The [SOLVED?] tag means that the problem solved, but I think this is not a proper solution for it. It needs investigation any maybe some actions on the upgrade scipts (on Zentyal side or on SOGo packaging side).
Pages: [1] 2 3 ... 10