Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Ret

Pages: [1] 2
1
Other modules / Re: Endless login popups from Proxy
« on: December 29, 2021, 03:06:15 pm »
UPDATE: Better solution
After using my "all" workaound I've run into a new problem: When a user belongs to multiple groups and those groups have to different profile rules. If any of those profiles uses whitelists that block sites " not listed", squid won't let the user access sites that were whitelisted in another profile.

So, the solutions I've foiund is to remove the lines "http_access deny  authorized grp~MYGROUP" altogether. That's because there's already a rule denying all access to everyone at the end of squid.conf and this way; So that will let squid check if a user can access domains that are whitelisted in a different group before denying access.

Hope this helps!!

2
Spanish / Re: Error al Ver los Registros en Zentyal 7.0
« on: December 06, 2021, 09:24:55 pm »
Es este bug?.
https://github.com/zentyal/zentyal/issues/2082
Aparentemente es provocado porque caduca el tiempo de sesion de webadmin

provisoriamente se arregla reiniciando el modulo webadmin "sudo zs weabadmin restart"

3
Other modules / Endless login popups from Proxy
« on: November 09, 2021, 10:49:01 pm »
I've been using Zentyal 2.2 for a long time  but now I'm preparing to migrate to 7.0
I've installed 7.0 but I'm experiencing problems with proxy module:

I need to use a filter profile that lets a group of users surf only to specific sites. So I add those domains in a list with their " allow" rules. I also enable the checkbox "Block not listed domains and URLs".
The problem is that all borwsers keep on asking for login credentials. (Same issue experienced by this users: https://forum.zentyal.org/index.php?topic=22446.0 )

I think I've found the solution.
 According to Squid Wiki: https://wiki.squid-cache.org/action/show/Features/Authentication?action=show&redirect=SquidFaq%2FProxyAuthentication
we could use the "all"  hack in squid.conf. That is, we should add "all" at the end of the deny ACL

excerpt from original  squid.conf
Code: [Select]
http_access allow  authorized grp~MYGROUP fltr2~df~dmn1
http_access deny  authorized grp~MYGROUP

fixed squid.conf
Code: [Select]
http_access allow  authorized grp~MYGROUP fltr2~df~dmn1
http_access deny  authorized grp~MYGROUP all

With this last line squid accepts login credentials from browsers and let users surf to the allowed domains and deny all others. There are no more endless login popups.

Developers: do you think you could add this fix (or a proper one) ?
Thank you!



4
Installation and Upgrades / Error restoring Config Backup
« on: October 27, 2021, 03:28:55 pm »
I'm trying to restore a configuration backup on my up-to-date Zentyal 7.0  but I get the error:
Code: [Select]
root command ln /var/lib/samba/private//sam.ldb.d/DC*FORESTDNSZONES* /var/lib/samba/bind-dns//dns/sam.ldb.d/ failed.
Error output: ln: target '/var/lib/samba/bind-dns//dns/sam.ldb.d/' is not a directory: No such file or directory Command output: . Exit value: 1

I think the error is that there are 2 backslashes in the file string. Maybe the problem is in Samba.pm file maybe in the declaration of the constant?

I couldn't find an answer online.

5
Email and Groupware / Re: Fetchmail and Gmail: Oauth required [SOLVED]
« on: January 09, 2020, 11:53:07 pm »
It seems that in 2021 Google will enforce the use of Oauth and block access to "Less secure apps"(LSA)
They sent an email to all admins to take actions.
This is part of their announcement,

Access to LSAs will be turned off in two stages:

June 15, 2020 - Users who try to connect to an LSA for the first time will no longer be able to do so. This includes third-party apps that allow password-only access to Google calendars, contacts, and email via protocols such as CalDAV, CardDAV and IMAP. Users who have connected to LSAs prior to this date will be able to continue using them until usage of all LSAs is turned off.
February 15, 2021 - Access to LSAs will be turned off for all G Suite accounts.


Let's hope Zentyal can solve this on time!

6
Installation and Upgrades / Re: VLAN configuration issues.
« on: May 24, 2012, 05:07:01 pm »
Oh.. ok. So you simplified your scenario to post in this forum ;).

You should take into account that Zentyal is tagging with 1 the frames that go through eth0. Maybe your switch is discarding that traffic and that is why it doesn't respond to ping. Take a look at your switch configuration as I think your problem is on port 49 setup.


PS: I don't know why zentyal doesn't allow us to set an IP address for the untagged eth0 interface while it is configured as trunk (802.1q) (You can set it up on the console though.)

7
Installation and Upgrades / Re: VLAN configuration issues.
« on: May 23, 2012, 04:58:27 pm »
It seems you don't need VLAN tagging. What you need is to set up zentyal as a simple gateway between your LAN and your ISP. You don't even need to configure the port on your switch.
As you have two network interfaces you just need to set eth0 as internal and eth1 as "external".

you use VLAN tagging (802.1q) when a port on your switch has to carry traffic for different Virtual LANs (called Virtual because you just have only one switch)
For example: if you would have had only one NIC that received traffic from your LAN (untagged) and also traffic from your ISP through Virtual LAN (802.1q tagged frames).

8
Installation and Upgrades / Execute custom code on event?
« on: May 09, 2012, 11:13:24 pm »
I wonder if it's possible execute custom code (eg shell script) when an Event takes place.
Maybe have a new dispatcher or something.
Actually, I want to run some code when my internet goes down. (The code would access my router's web admin page)
Any help?

9
I'm trying to use HTTP proxy module to authorize and filter users internet navigation. After adding users and groups to the system I define a filter profile. When I try to bind that filter profile with a group in "Groups' policies" I get the error: "An internal error related to a template has occurred. This is a bug, relevant information can be found in the logs."

Output of /var/log/zentyal/zentyal.log
Code: [Select]
2012/05/02 19:52:16 ERROR> ClientRawBase.pm:209 EBox::CGI::ClientRawBase::__ANON__ - Not a HASH reference at /usr/share/perl5/EBox/Squid/Model/GroupPolicyBase.pm line 114, <GEN0> line 2019.

Stack:
  [/usr/share/perl5/EBox/Squid/Model/GroupPolicyBase.pm:114]
  [/usr/share/perl5/EBox/Types/Select.pm:151]
  [/usr/share/zentyal/templates/ajax/setter/selectSetter.mas:25]
  [/usr/share/zentyal/templates/ajax/typeRowLayout.mas:21]
  [/usr/share/zentyal/templates/ajax/modelViewer.mas:326]
  [/usr/share/zentyal/templates/ajax/modelViewer.mas:226]
  [/usr/share/zentyal/templates/ajax/modelViewer.mas:261]
  [<anonymous component>:174]
  [/usr/share/zentyal/templates/ajax/modelViewer.mas:161]
  [/usr/share/zentyal/templates/ajax/modelViewer.mas:33]

I've installed Zentyal 2.3 (64bits) from its own CD and also from PPA into a clean Ubuntu 12.04 installation and upgraded all packages. In both systems I get the same result.
Do you know how to solve this situation? any help will be appreciated! ;)

10
I'd say, that is not a problem with Zentyal but with Ubuntu.
I experienced something similar with the onboard NIC card in my Intel mobo. In my case the solution was to upgrade the Linux kernel to 2.6.38 version. Lucid repositories don't have that kernels so you'd have to add them manually or with new repositories.

I recently installed a test Zentyal box but it does not detect an onboard gigabit card.  How do I force it to use a card or add an additional card?  Zentyal 2 RC2

11
Hola,
Creo que no hay una opcion en Zentyal para lo que buscas.
La solucion estaria en configurar Postfix de manera manual.
Fijate en este link:
http://www.freespamfilter.org/forum/viewtopic.php?t=659

Modifican /etc/postfix/main.cf y generar listas hash de usuarios y de sitios bloqueados.

Seria bueno tener opciones en Zentyal para esto: algo muy parecido a las configuraciones que ya tenemos en HTTP proxy.
Suerte

12
I think it's fixed now. Thanks!

13
Installation and Upgrades / Re: 2.2rc2: error while browsing logs
« on: August 29, 2011, 03:49:01 pm »
Hi, I've installed Zentyal 2.1 though ppa in a clean Ubuntu Server 10.04.3 system.
I experience exactly the same as christian: When accessing logs I get "An internal error related to a template has occurred. This is a bug, relevant information can be found in the logs."

This is "dpkg -l | grep zentyal" output
Code: [Select]
ii  libhtml-mason-perl                     1:1.44-1+zentyal1                 HTML::Mason Perl module
ii  libjs-jquery                           1.5-2ubuntu1+zentyal1             JavaScript library for dynamic web applicati
ii  liblog-any-perl                        0.11-1+zentyal1                   Log anywhere
ii  zentyal                                2.1                               Zentyal - Core
ii  zentyal-antivirus                      2.1.3                             Zentyal - Antivirus
ii  zentyal-common                         2.1.8                             Zentyal - Common Library
ii  zentyal-core                           2.1.27                            Zentyal - Core
ii  zentyal-firewall                       2.1.6                             Zentyal - Firewall
ii  zentyal-network                        2.1.11                            Zentyal - Network Configuration
ii  zentyal-objects                        2.1.3                             Zentyal - Network Objects
ii  zentyal-services                       2.1.7                             Zentyal - Network Services
ii  zentyal-software                       2.1.11                            Zentyal - Software Management

14
News and Announcements / Re: Zentyal 2.2-rc2 available!
« on: August 27, 2011, 01:20:39 am »
Hi, I want to install Zentyal 2.2rc2 and tune it for production until we upgrade for final release.
I have Ubuntu Lucid Server installed and I'd like to install Zentyal from respositories. Which is the address where they are located?
So far I've only found this one "deb http://ppa.launchpad.net/zentyal/2.1/ubuntu lucid main" Is this correct? (I guess not)
Thank you!


15
Spanish / Re: Sobre el servidor de correo electrónico
« on: June 23, 2011, 04:49:27 pm »
Si quieres enviar mail usando los servers de gmail como smarthost y que no modifique el remitente, necesitas modificar las configuraciones de postfix para que use una base de datos de usuarios como indica esta pagina.

http://serverfault.com/questions/123267/how-do-i-config-postfix-to-use-multiple-google-apps-user-accounts

Seria bueno que esto estuviera integrado en Zentyal ya que si un usuario cambia su clave, las bases de datos de postfix tienen que ser actualizadas tambien.
Saludos

Pages: [1] 2