Zentyal Forum, Linux Small Business Server

Zentyal Server => Installation and Upgrades => Topic started by: ap1821 on August 01, 2013, 06:17:01 pm

Title: [SOLVED?]VPN doesn't work when the port is set to 1194/UDP
Post by: ap1821 on August 01, 2013, 06:17:01 pm
Hi. I mentioned this in a other thread (http://forum.zentyal.org/index.php/topic,16788.msg66534.html#msg66534), but I have a problem with VPN. Recently we bought a new server to our office and I started preconfiguring it. Some days ago I brought it to our office and plugged in, did basic ip config and it works very well and I have a lot of services running with no problems. Altrough there is now a little problem with VPN.
When I set a port which is not 1194/udp (default openvpn port) the VPN seems to work (clients are able to connect from the internet), but with 1194 set the traffic of my internal interface (eth1) stops (clients of eth1 cant access anything) and there is no access to VPN. After messing up with it now the internal network works (!) with port set to 1194/udp, but there seems still to be a problem with firewall as far as I can tell.
When I set the port to 1194 and do
Code: [Select]
sudo iptables -L | grep 1194then it outputs nothing, when I set the port to 1195 for example then
Code: [Select]
sudo iptables -L | grep 1195outputs the firewall rule. When I was preconfiguring the server at home, the VPN worked trough 1195 with no problems.

The problem is that our ISP has a firewall and allows to the internet only HTTP traffic over port 80/443 and VPN traffic over 1194. I have to deal with ISP in order to properly forward the new port (lets say 1195), which is a mess so I would prefer to get the old 1194 working.  :) Anyway it should have worked by default, but somehow it doesnt.
Anyways I'm having a pretty great expirience with Zentyal 3.0 and I am pretty impressed of all the new features it has. Also tried the transparent proxy thing which was unplanned and it is very responsive and hope it will be stable, because I had issues with squid in Zentyal 2.2, had to increase some url stuff (cant remember now) to make it not to hang when the usage was high.
Title: Re: VPN doesn't work when the port is set to 1194/UDP
Post by: EddieA on August 03, 2013, 01:30:19 am
Instead of 'grep 1194', try 'grep openvpn'.  Or 'iptables -L -n | grep 1194'.

One thing I noticed when I first set up VPN is that even though it's set up via Zentyal panels, it didn't automatically add the firewall rule to let the packets in.  I had to manually add that via the Network and Firewall settings.

Title: Re: VPN doesn't work when the port is set to 1194/UDP
Post by: ap1821 on August 06, 2013, 02:06:46 pm
Yeah, I figured that out already. The VPN started working for me after the internal network connection loss problems disapeared.