Author Topic: External HTTP Proxy  (Read 1352 times)

elliotbeken

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
External HTTP Proxy
« on: January 18, 2012, 05:34:13 pm »
Hi all,

I have a zentyal firewall running 2.2 (64-bit) and i have been having some trouble with the HTTP proxy and the domain blocking rules.

Here is the network layout:

ADSL Router =eth0= Zentyal Firewall =eth1= Internal LAN

I have all the computers in the LAN set to access the web via the Firewall (10.0.0.1) and all works ok but if i add sites i want to block to the default filter they dont block the site by domain name it only works if i add the IP address..


What am i doing wrong ?

Thanks.

B_Khuwera

  • Zen Monk
  • **
  • Posts: 51
  • Karma: +0/-1
    • View Profile
Re: External HTTP Proxy
« Reply #1 on: January 21, 2012, 02:10:28 am »
Hi elliotbeken,

I have the same setup as you had. But never experience your issue.
it looks like a DNS issue, but your LAN client are connected as usual right.
I put the blocked site without the ¨www.¨
or just uninstall the HTTP Proxy (Cache and Filter) module .. and then reinstall,
do copy the squid.conf under /etc/squid/, as preference also under stubs folder, and under /etc/zentyal/hooks/squid.xxxxx if you change/add manual you own setting.

Hope it helps

Khuwera

elliotbeken

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: External HTTP Proxy
« Reply #2 on: January 23, 2012, 12:37:16 pm »
Thanks for the reply.

i have reinstalled the service and set it all back up fine.

the squid url block works fine from within the LAN so if i block elliotbeken.com = LAN PC - Zentyal(with block rule) - website

but if i access the squid externally so = remote site - zentyal (external) through http proxy filter - to website (elliotbeken.com)

it wont work while accessing the http proxy from a external location. (the proxy server from a external location works fine but it seems the block, filter does not apply to this traffic).


Thanks