Author Topic: OpenVpn + Clients perdant leur connection internet  (Read 2351 times)

marc@trainingconnect

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
OpenVpn + Clients perdant leur connection internet
« on: December 09, 2011, 04:07:53 pm »
Bonjour,
j'ai parcouru le forum et ne trouve pas exactement mon probleme.
Certains clients au module openVPN, principalement sous windows xp, perdent leur possibilité de naviguer sur le web lorsqu'ils sont connectés au VPN.
Ce probleme n'arrive pas avec mes client utilisant Windows seven.
Je pense que la version de windows n'est pas le probleme, mais qu'il s'agit plutot des options du serveur vpn qui empechent une navigation des clients une fois connectés.
Je dis bien navigation, parce que si j'utilise mon outil de controle a distance et de support, celui ci ne se deconnecte pas du pc client, mais toute tentative d'affichage d'une page web se solde par un echec.
Voici un apercu de la structure:
Zentyal est utilisé en tant que routeur, PDC et serveur VPN au siege
Il est connecté directement au web par son ETH0 avec une ip de type 83.xx.xx.xx fournie par notre FAI
ETH 1 sert de DHCP pour le reseau local avec une ip: 10.0.1.1
Le serveur VPN attribue des adresses situées en 192.160.160.xxx aux clients (cela limite le risque d'avoir des bureaux ayant la meme classe d'ip en reseau local).
Si quelqu'un a une idée de pourquoi cette perte de connection web des clients, et des parametres a changer (sur le serveur ou sur les clients) ?
Ou si quelqu 'un a la solution ?
Je suis prenneur ;)
Merci d'avance de vos réponses et de votre temps.

Amicalement.

Marc

marc@trainingconnect

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: OpenVpn + Clients perdant leur connection internet
« Reply #1 on: December 15, 2011, 12:52:01 pm »
Un ptit up ^^ ?
Pour info je pense a une galere avec les dns, vue que sur les postes clients, si j'utilise l'ip au lieu des url, cela fonctionne.
En tous cas, je n'ai tjrs pas trouvé de solution concrete.
Amicalement
« Last Edit: December 15, 2011, 12:55:10 pm by marc@trainingconnect »

christian

  • Guest
Re: OpenVpn + Clients perdant leur connection internet
« Reply #2 on: December 15, 2011, 02:03:13 pm »
Il ne s'agirait donc pas d'une "perte de connexion" mais de l’impossibilité de naviguer sur le web ?

1 - Tes clients utilisent-ils Zentyal comme proxy ?
2 - en effet, le serveur VPN ne pousse pas les options permettant a Zentyal d’être vu comme serveur DNS des clients VPN  :(

marc@trainingconnect

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: OpenVpn + Clients perdant leur connection internet
« Reply #3 on: December 15, 2011, 06:39:16 pm »
En effet, il s'agit de l'impossibilité de naviguer sur le web et non pas une perte totale de connection.
Mes clients sont sur des sites distants disposant de leur propre structure réseau (et donc pas de serveur zentyal :( ).
J'ai pensé au probleme de "push DNS" parce que mon outil de controle a distance fonctionnait sans probleme, mais pas leur navigation web.
Quote
2 - en effet, le serveur VPN ne pousse pas les options permettant a Zentyal d’être vu comme serveur DNS des clients VPN  :(
Voila la source du probleme.
Actuellement je l'ai corrigé en demandant aux utilisateurs du VPN de regler manuellement leurs serveurs DNS dans leurs options réseau. Cela n'est pas la méthode la plus esthetique, mais au moins pour un temps, cela me suffit pour resoudre ce probleme.
Je jetterai un coup d'oeil a la doc d'open-vpn pour voir si y a pas un petit truc a faire de ce coté la, et si oui, je laisserai trainer ici la méthode.
En tous cas, merci du boulot fait avec Zentyal qui pour pas mal d'autres choses, m'a reellement simplifié la vie ;)
PS: désolé pour les accents, mais un clavier qwerty refroidi mes ardeurs a les mettre correctement ^^.
Amicalement.
« Last Edit: December 15, 2011, 06:41:17 pm by marc@trainingconnect »