Author Topic: zentyal-zarafa uninstallable  (Read 2699 times)

airtonix

  • Zen Apprentice
  • *
  • Posts: 30
  • Karma: +2/-0
    • View Profile
zentyal-zarafa uninstallable
« on: July 01, 2012, 08:32:52 am »
Code: [Select]
$ cat /etc/apt/sources.list.d/zentyal-2_3-precise.list
deb http://ppa.launchpad.net/zentyal/2.3/ubuntu precise main
deb-src http://ppa.launchpad.net/zentyal/2.3/ubuntu precise main



Code: [Select]
$ sudo apt-cache show zentyal-zarafa
Package: zentyal-zarafa
Priority: optional
Section: web
Installed-Size: 208
Maintainer: José Antonio Calvo <jacalvo@zentyal.org>
Architecture: all
Version: 2.3
Replaces: ebox-zarafa (<< 2.0.100)
Depends: zentyal-core (>= 2.3), zentyal-core (<< 2.3.100), zentyal-mail, zentyal-webserver, zarafa, zarafa-webaccess, zarafa-webapp, aspell
Filename: pool/main/z/zentyal-zarafa/zentyal-zarafa_2.3_all.deb
Size: 30812
MD5sum: 892b9cade75efcb899ab2a0602078d05
SHA1: 7e7b21a2f31b484ff55b3c8390117fcfd7be803c
Description: Zentyal - Groupware (Zarafa)
 Zentyal is a Linux small business server that can act as
 a Gateway, Unified Threat Manager, Office Server, Infrastructure
 Manager, Unified Communications Server or a combination of them. One
 single, easy-to-use platform to manage all your network services.
 .
 This module adds Zarafa integration with Zentyal.

Code: [Select]
$ sudo apt-get install zentyal-zarafa
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zentyal-zarafa : Depends: zarafa but it is not installable
                  Depends: zarafa-webaccess but it is not installable
                  Depends: zarafa-webapp but it is not installable
E: Unable to correct problems, you have held broken packages.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: zentyal-zarafa uninstallable
« Reply #1 on: July 01, 2012, 11:20:21 am »
As you can see in the installation guide:

Quote
The groupware module (zentyal-zarafa) needs an extra repository added in /etc/apt/sources.list:

deb http://archive.zentyal.org/zentyal 2.3 main extra

Of course this is not necessary if you use the Zentyal 2.3-1 installer.
Zentyal Server Lead Developer

airtonix

  • Zen Apprentice
  • *
  • Posts: 30
  • Karma: +2/-0
    • View Profile
Re: zentyal-zarafa uninstallable
« Reply #2 on: July 01, 2012, 03:55:24 pm »
perhaps then, when you make exclamations about how something is "included" it would probably be a nice thing to say:

Code: [Select]
+ Zarafa 7.1 included (by enabling extra repos)

instead of

Code: [Select]
+ Zarafa 7.1 included

or even provide a link to the installation guide from your Fan Fare Blog post that seeks to bring lots of attention on your new releases.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: zentyal-zarafa uninstallable
« Reply #3 on: July 04, 2012, 07:01:06 am »
The announce was about the new Zentyal 2.3-1 installer, so it was true that Zarafa 7.1 was included on it without enabling anything. But you are right, we could have add a note for people interested on installing it directly on Ubuntu server. We'll try to avoid this kind of confusions in the future. Thanks for the feedback!
Zentyal Server Lead Developer