Author Topic: (SOS) Problème Proxy http  (Read 1452 times)

anias

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
(SOS) Problème Proxy http
« on: October 25, 2011, 05:18:27 pm »
Bonjour,
J’ai un problème sur mon serveur ZENTYAL, après quelque modification au niveau de module Proxy.
J’ai un reporte d’erreurs lors de la sauvegarde des modifications.
Voici le message :
Quelques modules ont reporté des erreurs lors de la sauvegarde . Plus d'informations sont disponibles dans les rapports d'événements sous /var/log/ebox/
Can't call method "valueByName" on an undefined value.

J'ai même désinstallée le module proxy HTTP puis réinstallé a nouveau, toujours le même problème j'arrive pas a faire démarrer ce module(Proxy HTTP).
#apt-get remove --purge ebox-squid
#apt-get install ebox-squid

voici une partie de log: ebox.log
********************************************************************************************
2011/10/25 07:17:22 INFO> EventDaemon.pm:307 EBox::EventDaemon::_loadModules - EBox::Event::Dispatcher::Log loaded from registeredDispatchers
2011/10/25 08:12:20 ERROR> Base.pm:346 EBox::CGI::Base::__ANON__ - Can't call method "id" on an undefined value at /usr/share/ebox/templates/ajax/tableBody.mas line 260, <GEN47> line 10161.

Stack:
  [/usr/share/ebox/templates/ajax/tableBody.mas:260]
  [/usr/share/ebox/templates/ajax/modelViewer.mas:151]
  [/usr/share/ebox/templates/ajax/modelViewer.mas:69]
  [/usr/share/ebox/templates/ajax/tableBody.mas:19]
  [/usr/share/ebox/templates/ajax/composite.mas:53]
  [/usr/share/ebox/templates/ajax/tabMenu.mas:61]
  [/usr/share/ebox/templates/ajax/composite.mas:42]
  [(eval 3180):181]
2011/10/25 08:12:29 ERROR> Base.pm:346 EBox::CGI::Base::__ANON__ - Can't call method "id" on an undefined value at (eval 3324) line 664, <GEN47> line 10171.

Stack:
  [(eval 3324):664]
  [/usr/share/ebox/templates/ajax/modelViewer.mas:151]
  [/usr/share/ebox/templates/ajax/modelViewer.mas:69]
  [/usr/share/ebox/templates/ajax/modelViewer.mas:28]
********************************************************


Merci d'avance
« Last Edit: October 27, 2011, 10:01:03 am by anias »

christian

  • Guest
Re: (SOS) Problème Proxy http
« Reply #1 on: October 25, 2011, 06:08:08 pm »
Probablement qu'il est préférable en parallèle, d'ouvrir un ticket.
 http://trac.zentyal.org/newticket

Comment cette erreur est-elle apparu ?
Ton serveur fonctionnait-il correctement avant ?

anias

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: (SOS) Problème Proxy http
« Reply #2 on: October 25, 2011, 06:47:11 pm »
bonjour et merci beaucoup pour votre réponse.

- pour l'histoire de ticket c'est déjà faire hier (toujours j'ai pas de réponse).
- Cette erreur est-elle apparu lorsque j'ai essai de changer l'état de profil de filtre d'un état très permissif en état de filtre(dans le profil par défaut de zentyal (proxy HTTP).

- Pour l'état de mon serveur oui il fonctionnait très bien depuis 2 ans avec tout les mises a jours.

Merci d'avance

anias

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: (SOS) Problème Proxy http
« Reply #3 on: October 26, 2011, 12:47:37 pm »
Bonjour,
j'ai réglé le problème avec une restauration d'une sauvegarde système.

Merci et bon courage.