Author Topic: DHCP Server Not Assigning Addresses  (Read 2321 times)

chris.zeman

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
DHCP Server Not Assigning Addresses
« on: January 20, 2008, 03:48:59 am »
I installed eBox today, and am looking forward to installing it at work on Monday. I've used IPCop, BrazilFW, Endian, and others, but I think eBox is probably the perfect solution for me. I thought I remembered reading somewhere some time ago and that eBox will be switching to Ubuntu at some point. I sure hope so! :) I know Ubuntu is based off of Debian, but the Ubuntu team sure does a nice job cleaning up Debian.

Anyways...
I enabled the DHCP Server and have an address ranges assigned, but both of my machines aren't receiving address assignments from the server. Am I possibly missing something, or has anybody else run across this?

Thank you,
Chris

javi

  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
Re: DHCP Server Not Assigning Addresses
« Reply #1 on: January 20, 2008, 04:09:49 pm »
Which version have you installed?

Have you actually enabled the DHCP service and what's its status as listed on the Status page?

chris.zeman

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: DHCP Server Not Assigning Addresses
« Reply #2 on: January 20, 2008, 06:03:01 pm »
eBox 0.11. Yes, I enabled the DHCP service and it's listed as running on the Status page.



« Last Edit: January 20, 2008, 06:09:04 pm by chris.zeman »

sixstone

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1417
  • Karma: +26/-0
    • View Profile
    • Sixstone's blog
Re: DHCP Server Not Assigning Addresses
« Reply #3 on: January 20, 2008, 08:03:00 pm »
I think it's already fixed bug. The problem comes up when the fixed address mappings contain spaces which dhcpd3 server does not allow in the configuration file.

So if you remove any white space from the name in the fixed address row, you'll have your DHCP server fully serving IP addresses.

Best regards,
My secret is my silence...

chris.zeman

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: DHCP Server Not Assigning Addresses
« Reply #4 on: January 20, 2008, 10:34:31 pm »
Ahhh....that did it! Thank you so much!!! Oh, I also had to get rid of the colon. Everything is working great now!

Thanks again!
Chris