Author Topic: [RESOLU]Installation RC2 qui bloque à 84%  (Read 2010 times)

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
[RESOLU]Installation RC2 qui bloque à 84%
« on: September 04, 2011, 03:05:14 pm »
Bonjour à tous !
Petit nouveau ici, j'ai décidé d'utiliser Zentyal sur mon serveur dédié pour son interface d'administration à distance un peu plus user-friendly que Webmin et ça simplicité de mise en oeuvre (enfin du moins je croyais ).

J'ai mis l'iso sur un clé USB ( via Multisystem, un logiciel pour créer des clé usb multiboot ) et me suis donc lancé dans l'installation de l'OS.

Première surprise, par rapport aux tuto, aucune interface graphique au lancement, je tombe directement en mode ligne de commande.
La deuxième, une erreur dans la récupération du fichier de préconfiguration, que le système n'arrive pas à récupérer depuis le chemin ://cdrom ( alors que je boot depuis une clé usb ).

Et n'en suit que des problèmes, carte réseau non reconnue, noyaux différent de celui de l'archive etc ...
Malgré cela l'installation continue de bon train. Jusqu'au stade de l'installation des logiciels, où le système bloque à 84%.

En me mettant sur le terminal 4 ( ctrl+alt 4 ), l'installation bloque sur :

Code: [Select]
root : TTY=unknown ; PWD =/ ; USER=ebox ; COMMAND=/usr/bin/redis-server /var/lib/zentyal//conf/redis.first
ebox : TTY=unknown ; PWD =/ ; USER=root ; COMMAND=/var/lib/zentyal/tmp/X.cmd
in-target: Use of uninitialized value $status in pattern match at /usr/share/perl15/Ebox/Service.pm line 82
ebox : TTY=unknown ; PWD =/ ; USER=root ; COMMAND=/var/lib/zentyal/tmp/X.cmd
ebox : TTY=unknown ; PWD =/ ; USER=root ; COMMAND=/var/lib/zentyal/tmp/X.cmd

Où X est un nom de fichier variable en alphanumérique mélangeant chiffres, lettres majuscule/minuscule.
Et ça fait une demie-heure que c'est comme ça :/

Du coup j'aimerais bien savoir qu'est-ce qui couille.


La config de mon serveur :

Quote
CM = Gigabyte GA-D525TUD
RAM = G.Skill Value DDR3 4 Go PC10600 NT   
DD Système = Western Digital Caviar RE4 S-ATA - 250 Go - 64 Mo


Merci d'avance pour votre aide ;)

P.S : j'ai essayé à la fois la RC2 et la version stable, la stable bloque au même endroit ( mais sur ebox au lieu de zentyal-core )
« Last Edit: September 04, 2011, 10:02:05 pm by Hellow »

christian

  • Guest
Re: Installation RC2 qui bloque à 84%
« Reply #1 on: September 04, 2011, 03:56:37 pm »
Je ne sais pas trop t'aider  :-[

J'ai installé il y a quelques jours la 2.2rc2 à partir d'une lcé USB et n'ai pas rencontré le moindre problème.

Tu devrais, si ce n'est pas dejà fait, essayer d'installer Ubuntu 10.04, soit à partir d'une clé USB ou d'un CD pour vérifier que le problème ne vienht pas de ta config hardware qui poserait des soucis à Ubuntu.

Par ailleurs, du moins avec la 2.2rc2, pas de ligne commande... si tout se passe bien  ;)
Lorsque tu bootes, il devrait y avoir un splash "Zentyal" puis quelques écrans pour renseigner des choix basiques mais pas de CLI.

Si le problème n'existe pas avec Ubuntu mais uniquement avec Zentyal, je te suggère d'ouvrir un ticket d'incident. Dans le cas contraire, c'est plus vers un forum Ubuntu ou Debian qu'il faut s'orienter.

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Installation RC2 qui bloque à 84%
« Reply #2 on: September 04, 2011, 04:18:18 pm »
Il semblerais que ma clé usb déconne effectivement.
J'utilise une NoName venant de Boulanger qui fait 8Go ( de quoi mettre pas mal de live cd dessus :) ) et maintenant elle est carrément plus reconnue sur Windows :/

Du coup, je suis parti sur une installation d'Ubuntu 11.04 server et j'installerais Zentyal par dessus fut que le dépôt est maintenant pré-configuré dans la 11.04.
L'installation s'est fait sans aucun soucis ( ce qui confirme le problème de clé usb ).

Vraiment triviale comme problème.

Merci tout de même pour ta réponse  ;D

christian

  • Guest
Re: Installation RC2 qui bloque à 84%
« Reply #3 on: September 04, 2011, 04:49:53 pm »
11.04 n'est pas le meilleur choix... Zentyal ne support que les LTS (donc 10.04 ici). ça ne veut pas dire pour autant que ça ne marche pas en 11.04   ;)

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Installation RC2 qui bloque à 84%
« Reply #4 on: September 04, 2011, 05:10:12 pm »
Certes, mais pour ma part, ça marche comme sur des roulettes pour le moment.
Installation de Zentyal sans soucis, paramétrage idem ... bref aucun soucis :)

Après je ne sais pas ce qui change entre l'iso téléchargeable Zentyal et le fait de l'installer en plus sur un serveur ubuntu. Noyau mieux optimisé ?

christian

  • Guest
Re: Installation RC2 qui bloque à 84%
« Reply #5 on: September 04, 2011, 05:23:58 pm »
non, rien. Mon point n'est pas l'ISO Zentyal vs. Ubuntu + apt-get install Zentyal.

Pour avoir testé la 2.2rc2, je pense que l'install serveur Ubuntu + Zentyal est même mieux que l'ISO Zentyal car cela ne t'oblige pas à installer d'interface graphique, ce que fait l'ISO Zentyazl.
Mon propos c'est la difference entre 10.04 et 11.04
Avec un serveur 10.04, tu un support de l'équipe Zentryal car c'est leur base de référence. Avec 11.04, pas de support ou alors "best effort mode". A partir de là, c'est toi qui voit  ;D

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Installation RC2 qui bloque à 84%
« Reply #6 on: September 04, 2011, 06:09:52 pm »
J'avais compris pour le support des versions hein  8)

Bref, je vais tout de même reformater pour aller en Ubuntu Server 10.04 pour éviter d'avoir des couilles :)*
Parce que en faite, sur 11.04 ça tournait bien au début, puis une fois Zentyal installé et la machine redémarrée, elle met deux minutes pour me log :'(

christian

  • Guest
Re: Installation RC2 qui bloque à 84%
« Reply #7 on: September 04, 2011, 06:34:16 pm »
Tu veux dire avec l'interface web ?
c'est normal  :-X  enfin, pas 2 minutes montre en main mais l'interface web est d'une manière générale assez lente, et particulièrement lors de l’authentification. ça va (un peu) mieux avec la 2.2 mais rien de transcendant non plus.

Si tu mets 2 minutes en SSH, alors là il y a un vrai problème.

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Installation RC2 qui bloque à 84%
« Reply #8 on: September 04, 2011, 07:05:11 pm »
Je parlais même pas en SSH mais en directe sur la machine ( j'ai la chance de l'avoir à porter de main ).
Surement les modules Zentyal qui doivent pas aimer la 11.04  ???

christian

  • Guest
Re: Installation RC2 qui bloque à 84%
« Reply #9 on: September 04, 2011, 07:08:40 pm »
non, je ne pense pas...  :o

1 - As-tu des messages "suspects" dans syslog?
2 - laisses-tu à la machine le temps de démarrer "complètement" avant de vouloir t'authentifier ?

Hellow

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Installation RC2 qui bloque à 84%
« Reply #10 on: September 04, 2011, 07:17:51 pm »
A part des modules Zentyal qui arrivent pas à ce charger au démarrage de la machine, rien de trop suspects.
Le serveur met déjà a peu près 3/4 minutes à démarrer et à être opérant.
Une fois qu'Ubuntu a finis de boot et que la console de log apparaît, je lui laisse grosso modo une minute.

Mais même une fois log, lorsque je fais un sudo, l'action met un certain moment avant de se lancer une fois le pwd rentré.

Je vais installer la 10.04 et basta. Ça fait déjà deux jours que je planche dessus ( j'ai eu d'autres problème d'installation avec Debian à cause de ma clé défaillante et des soucis de config ).


Edit : je passe le topic en résolu :)
« Last Edit: September 04, 2011, 10:02:30 pm by Hellow »