Author Topic: Zentyal management web interface won't start after reboot  (Read 39622 times)

icemanzor

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #45 on: February 01, 2012, 09:30:35 pm »
Thanks I could figure out what the administration panel Zentyal reinstalling with the command

sudo apt-get install Zentyal

now I have an error when trying to enable file sharing modules Zentyal log I get the following :-\


Stack:
  [/usr/share/perl5/HTML/Mason/Request.pm:127]
  [/usr/share/perl5/HTML/Mason/Request.pm:525]
2012/02/01 15:47:40 INFO> install-packages:56 main::__ANON__ - Starting package installation process
2012/02/01 15:47:41 ERROR> install-packages:89 main::__ANON__ - Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
2012/02/01 15:47:41 INFO> install-packages:116 main::__ANON__ - Package installation process finished
2012/02/01 15:47:56 INFO> GlobalImpl.pm:539 EBox::GlobalImpl::saveAllModules - Saving config and restarting services: firewall
2012/02/01 15:47:57 INFO> GlobalImpl.pm:653 EBox::GlobalImpl::saveAllModules - Changes saved successfully
2012/02/01 15:49:11 INFO> GlobalImpl.pm:539 EBox::GlobalImpl::saveAllModules - Saving config and restarting services: network antivirus bwmonitor mail openvpn samba trafficshaping firewall captiveportal printers
2012/02/01 15:49:11 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: network
2012/02/01 15:49:16 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: antivirus
2012/02/01 15:49:29 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: bwmonitor
2012/02/01 15:49:30 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: openvpn
2012/02/01 15:49:31 INFO> GlobalImpl.pm:653 EBox::GlobalImpl::saveAllModules - Changes saved successfully
2012/02/01 15:50:11 INFO> GlobalImpl.pm:539 EBox::GlobalImpl::saveAllModules - Saving config and restarting services: network antivirus bwmonitor mail openvpn samba trafficshaping firewall captiveportal printers
2012/02/01 15:50:11 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: network
2012/02/01 15:50:31 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: antivirus
2012/02/01 15:50:39 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: bwmonitor
2012/02/01 15:50:40 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: openvpn
2012/02/01 15:50:40 INFO> GlobalImpl.pm:653 EBox::GlobalImpl::saveAllModules - Changes saved successfully
2012/02/01 15:53:00 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 15:53:01 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 15:53:02 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 15:53:03 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 15:53:04 ERROR> Ldap.pm:1107 EBox::Ldap::safeConnect - FATAL: Couldn't connect to LDAP server: ldapi://%2fvar%2frun%2fslapd%2fldapi
2012/02/01 15:53:04 ERROR> ConfigureModuleController.pm:74 EBox::CGI::ServiceModule::ConfigureModuleController::__ANON__ - Failed to enable: FATAL: Couldn't connect to LDAP server: ldapi://%2fvar%2frun%2fslapd%2fldapi
2012/02/01 16:00:18 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:00:19 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:00:20 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:00:21 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:00:22 ERROR> Ldap.pm:1107 EBox::Ldap::safeConnect - FATAL: Couldn't connect to LDAP server: ldapi://%2fvar%2frun%2fslapd%2fldapi
2012/02/01 16:00:22 ERROR> ConfigureModuleController.pm:74 EBox::CGI::ServiceModule::ConfigureModuleController::__ANON__ - Failed to enable: FATAL: Couldn't connect to LDAP server: ldapi://%2fvar%2frun%2fslapd%2fldapi
2012/02/01 16:10:47 INFO> GlobalImpl.pm:539 EBox::GlobalImpl::saveAllModules - Saving config and restarting services: firewall samba printers logs
2012/02/01 16:10:48 INFO> Base.pm:228 EBox::Module::Base::save - Restarting service for module: logs
2012/02/01 16:10:48 INFO> GlobalImpl.pm:653 EBox::GlobalImpl::saveAllModules - Changes saved successfully
2012/02/01 16:11:17 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:11:18 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:11:20 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:11:21 ERROR> Ldap.pm:1103 EBox::Ldap::safeConnect - Couldn't connect to LDAP server ldapi://%2fvar%2frun%2fslapd%2fldapi, retrying
2012/02/01 16:11:22 ERROR> Ldap.pm:1107 EBox::Ldap::safeConnect - FATAL: Couldn't connect to LDAP server: ldapi://%2fvar%2frun%2fslapd%2fldapi
« Last Edit: February 01, 2012, 09:36:51 pm by icemanzor »

icemanzor

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #46 on: February 01, 2012, 10:12:25 pm »
Well try to start, stop and re start the service and I got the following

coraserver2 root @: ~ # / etc / init.d / slapd start
Not starting slapd: September SLAPD_NO_START in / etc / default / slapd
coraserver2 root @: ~ # / etc / init.d / slapd stop
Stopping OpenLDAP: slapd.
coraserver2 root @: ~ # / etc / init.d / slapd start
Not starting slapd: September SLAPD_NO_START in / etc / default / slapd

alvarog_silva

  • Zen Apprentice
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #47 on: January 29, 2018, 07:31:37 pm »
Hi

Try to 'install' again the package 'zentyal'

$ apt-get install zentyal

If you installed from the DVD, I don't know why, you have to install again to setup mysql passwords and stuff.


devnull

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #48 on: January 30, 2018, 02:51:49 pm »
I just got the same problem in Zentyal 5. After server reboot Zentyal management web interface is not working anymore. Sogo works. It seems that web managament interface uses nginx while sogo uses Apache.

/var/log/nginx/error.log:
Code: [Select]
[emerg] 4175#4175: SSL_CTX_use_PrivateKey_file("/var/lib/zentyal/conf/ssl/ssl.pem") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch)

sudo journalctl -xe:

Code: [Select]
-- Subject: Unit nginx.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nginx.service has failed.
--
-- The result is failed.
Jan 30 15:36:11 zentyal systemd[1]: nginx.service: Unit entered failed state.
Jan 30 15:36:11 zentyal systemd[1]: nginx.service: Failed with result 'exit-code'.
Jan 30 15:36:11 zentyal sudo[3594]: pam_unix(sudo:session): session closed for user root
Jan 30 15:36:31 zentyal sudo[3608]: PAM unable to dlopen(pam_cap.so): /lib/security/pam_cap.so: cannot open shared object
Jan 30 15:36:31 zentyal sudo[3608]: PAM adding faulty module: pam_cap.so
Jan 30 15:36:31 zentyal sudo[3608]:     kris : TTY=pts/0 ; PWD=/home/kris ; USER=root ; COMMAND=/bin/journalctl -xe
Jan 30 15:36:31 zentyal sudo[3608]: pam_unix(sudo:session): session opened for user root by kris(uid=0)


Edit:
Solved! I had to reinstall libpam-systemd... I've no idea how this could happened. I know that Ubuntu updates are always dangerous but this time it stopped working without updating anything. It looks bad for the future.
« Last Edit: February 03, 2018, 01:09:40 pm by devnull »