Author Topic: Zentyal management web interface won't start after reboot  (Read 39668 times)

spiral

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #15 on: August 26, 2011, 08:45:20 pm »
yep, still an issue here too with RC2

exekias

  • Zentyal Staff
  • Zen Warrior
  • *****
  • Posts: 196
  • Karma: +21/-0
    • View Profile
    • The Big Bug Theory
Re: Zentyal management web interface won't start after reboot
« Reply #16 on: August 26, 2011, 08:56:19 pm »
For those of you who are reproducing the issue:

Can you please review (or attach) your /var/log/zentyal/zentyal.log in order to find the problem during boot?

I'm trying to reproduce this but it always works for me  :-[

Thank you for your reports

itamar

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #17 on: August 26, 2011, 09:30:16 pm »
Happens to me all the time.
Attaching log but I can't find anything in it.
One more thing - upon restart the file sharing does not work too.
After I manually start the dashboard I have to click start from the dashboard to get the file sharing service to work.

maxprox

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #18 on: August 26, 2011, 10:06:40 pm »
Hello,

testing 2.2

also the same "no access" admin web interface.
After a reboot again no access
I have to stop apache and firewall
 
Code: [Select]
root@zentyal-vm:~# /etc/init.d/zentyal apache stop
 * Stopping Zentyal module: apache                                             [ OK ]
root@zentyal-vm:~# /etc/init.d/zentyal firewall stop
 * Stopping Zentyal module: firewall                                     [ OK ]
root@zentyal-vm:~# /etc/init.d/zentyal apache start
 * Restarting Zentyal module: apache                                     [ OK ]
root@zentyal-vm:~# /etc/init.d/zentyal firewall start
 * Restarting Zentyal module: firewall                                         [ OK ]
root@zentyal-vm:~#
         

Lo and behold! The web interface is reachable

by the way:
xorg uses 50-80 %CPU (use top)  => I have to kill it and work remote
what is with DNS? In the web interface I can't find settings for static DNS names to IP's ?

Okay I worked with an old SME-Server - and I go back :-(

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #19 on: August 26, 2011, 11:48:37 pm »
Yes same here.
restarting everything using
service zentyal start didn't help.
Only sudo /etc/init.d/zentyal apache restart did the trick
I can't believe that this bug hasn't been fixed yet....

If this hasn't been fixed yet it's just because we can't reproduce it. It's difficult to fix something that works for us...

Could you all who are reproducing it tell us the list of modules you have installed / enabled ? Maybe with that information we will be more lucky reproducing it...

Thanks in advance!
Zentyal Server Lead Developer

sinc

  • Zen Apprentice
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #20 on: August 27, 2011, 12:00:26 am »
This is 100% reproducible on all my fresh installs. My setup is a VMWare instance with two NICs, all I did was install from 2.2-rc2 ISO with all packages but mail related ones and it occurs on reboot. I also tried recreating the problem on another machine with a different VMWare install and created a new VMWare instance from scratch.

maxprox

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #21 on: August 27, 2011, 02:19:04 am »
Could you all who are reproducing it tell us the list of modules you have installed / enabled ? Maybe with that information we will be more lucky reproducing it...
Thanks in advance!
Yes
I have install and running on Core version 2.1.27.
(by the way I have killed x11-commen and lxdm because a very high load >50 %CPU
and I don't need it.)

Code: [Select]
Netzwerk Läuft
Firewall Läuft
Antivirus Läuft
Apache    Läuft
DHCP    Läuft
DNS      Läuft
Ereignis Läuft
Logs         Läuft
NTP        Läuft
Dateifreigabe Läuft
Benutzer und Gruppen Läuft

On the Firewall in the first rule I allow everything from the local Network as well ldap and adsync

bubbl3

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #22 on: August 27, 2011, 02:59:00 am »
Didn't have this problem in RC1 got it in RC2, nice....

itamar

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #23 on: August 27, 2011, 07:57:06 am »
I did a fresh install and selected the regular office configuration.
after setup finished I made some users and tested some shares and rebooted.
Then I encountered th problem.
BTW I'm running on virtual box but I did test the 2.0 the same way and didn't have any problem.

How do I list the list the services to copy here?

What else do you need to pinpoint the problem?
Would access via TeamViewer help.
I can set it up and send credentials via email.
« Last Edit: August 27, 2011, 08:01:52 am by itamar »

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #24 on: August 27, 2011, 01:47:48 pm »
Ok, we have finally reproduced it and the fix is going to be released asap. Thanks to everybody for the feedback and sorry for the inconvenience!
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #25 on: August 27, 2011, 01:49:33 pm »
Didn't have this problem in RC1 got it in RC2, nice....

That's really strange, do you have now the same set of modules you had in RC1?
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #26 on: August 27, 2011, 04:31:00 pm »
Hi again,

The fix is already published, you just need to upgrade to the last version of the zentyal-users package (2.1.10).

Please confirm that this is definitely fixed with that.

Thanks!
Zentyal Server Lead Developer

maxprox

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #27 on: August 27, 2011, 05:28:36 pm »
How do I list the list the services to copy here?
Hi itamar,

go to the first Admin screen from zentyal (I belive called "Dashboard)
there you will find an overview of all installed modules and their status.
=> copy and past

maxprox

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #28 on: August 27, 2011, 05:38:14 pm »
Please confirm that this is definitely fixed with that.

Hi

YES ! It goes!

Code: [Select]
Die folgenden Pakete werden aktualisiert:
  zentyal-users
1 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht
aktualisiert.
Muss 77,2kB an Archiven herunterladen. Nach dem Entpacken werden 0B zusätzlich
belegt sein.

Thank You for your work - super!



sinc

  • Zen Apprentice
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #29 on: August 27, 2011, 09:14:06 pm »
2.2-rc2 with latest updates seems to have fixed this problem for me.