Author Topic: Zentyal management web interface won't start after reboot  (Read 39667 times)

kaja

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +1/-2
    • View Profile
Zentyal management web interface won't start after reboot
« on: August 15, 2011, 10:54:09 pm »
I've installed all modules and after reboot I'm not able to connect to web management.
When I run /etc/init.d/zentyal apache start, the problem is fixed.

spiral

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #1 on: August 16, 2011, 07:25:16 pm »
Same issue here, I have been reinstalling zentyal core with apt-get, but will try restarting apache.

mervyn

  • Zen Apprentice
  • *
  • Posts: 40
  • Karma: +0/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #2 on: August 16, 2011, 09:45:01 pm »
Issue resolved for me with latest upgrade of Zentyal firewall, 2.1.4

spiral

  • Zen Monk
  • **
  • Posts: 59
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #3 on: August 16, 2011, 10:13:29 pm »
I am still having issues after the firewall update.  I still must restart apache.

sinc

  • Zen Apprentice
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile

robb

  • Guest
Re: Zentyal management web interface won't start after reboot
« Reply #5 on: August 21, 2011, 08:50:25 am »
What does /var/log/ebox/ebox.log say about this?

Also have a look at this thread: http://forum.zentyal.org/index.php/topic,7082.msg28417.html

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #6 on: August 21, 2011, 11:08:21 pm »
Is this reproducible all the times? I mean, if you execute /etc/init.d/zentyal apache restart it works and when rebooting the machine it fails again? or is it a random behavior?
Zentyal Server Lead Developer

sinc

  • Zen Apprentice
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #7 on: August 22, 2011, 09:12:41 pm »
The problem seems to occur at each reboot in my setup, which is a fresh install. Also, in response to robb, it was my understanding that 2.2 had ebox references removed which means /var/log/ebox/ebox.log is now /var/log/zentyal/zentyal.log

There doesn't appear to be any relevant errors in zentyal.log
« Last Edit: August 22, 2011, 09:17:41 pm by sinc »

Marcus

  • Forum Moderator
  • Zen Samurai
  • *****
  • Posts: 395
  • Karma: +12/-0
    • View Profile
    • Professional IT Service
Re: Zentyal management web interface won't start after reboot
« Reply #8 on: August 23, 2011, 02:02:13 am »
Hello,

I had the same experience few hours ago with an up-to-date zentyal 2.1.

rebooted than Zentyal was missing.

Code: [Select]
sudo /etc/init.d/zentyal startstarted Zentyal, mail filter failed along with the mail module and still no admin interface.

Code: [Select]
sudo dpkg-reconfigure zentyalstill nothing  - not even an error !! :(

Code: [Select]
sudo /etc/init.d/zentyal apache restart... yay!  Zentyal admin interface is back  ;D

Everything was back to what it was (after restarting the mail service).

Marcus


francesco_r

  • Zen Apprentice
  • *
  • Posts: 24
  • Karma: +1/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #9 on: August 23, 2011, 12:12:26 pm »
I have installed two 2.2 rc1 machines and both have this annoying bug.
Another bug is after the setup, the network don't start because in the gateway page there are two identical default gateway.
When i remove one of two, the network start normally.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Zentyal management web interface won't start after reboot
« Reply #10 on: August 25, 2011, 06:40:11 pm »
The two gateways is a different already reported issue, but regarding the won't start problem, could you try upgrading to the last packages (2.2-rc2) to see if it still happens?
Zentyal Server Lead Developer

kaja

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +1/-2
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #11 on: August 26, 2011, 12:25:05 am »
yep, it's the still same .... but the boot takes little bit longer

kaja

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +1/-2
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #12 on: August 26, 2011, 12:26:52 am »
and the internal network interface is unconfigured (in initial setup set as static). This happend after installing all modules and after reboot.

sinc

  • Zen Apprentice
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #13 on: August 26, 2011, 04:45:06 am »
Same problem with rc2 after fresh install, also, I noticed the Dashboard says there is 1 system update available after I updated from web interface, but none of the Software Management lists in the web interface show anything. I had to do it from the command line.
« Last Edit: August 26, 2011, 04:50:20 am by sinc »

itamar

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +2/-0
    • View Profile
Re: Zentyal management web interface won't start after reboot
« Reply #14 on: August 26, 2011, 08:48:15 am »
Yes same here.
restarting everything using
service zentyal start didn't help.
Only sudo /etc/init.d/zentyal apache restart did the trick
I can't believe that this bug hasn't been fixed yet....