Author Topic: Activer le certificat du serveur Web  (Read 2274 times)

Alexconquer

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Activer le certificat du serveur Web
« on: August 13, 2011, 11:21:04 pm »
Bonjour,

Voila je viens de passer récemment sous la version stable 2.0-4 (j'ai tester la bêta avant ;) ) et je rencontre un problème avec l'autorité de certification.

enfin uniquement avec l'activation du certificat du sevrer web qui ne veux absolument pas s'activer... alors que avec les autres services mail ou administration web etc.. le service de certification marche bien.

pour donner plus de détails, quand je change les paramètres (nom commun et activation du certificat) tout fonctionne bien, ensuite quand je sauvegarde les changement, il n'y a pas non plus de messages d'erreur tout semble fonctionner normalement ... mais quand je reviens sur la page service de certification la parti web sevrer est revenu au paramètre initial et donc déactivé.

j'ai lu les logs et j'ai trouvé ceci:

Quote
[Fri Aug 12 22:20:35 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Fri Aug 12 22:20:35 2011] [warn] RSA server certificate CommonName (CN) `Web' does NOT match server name!?
[Fri Aug 12 22:20:35 2011] [warn] RSA server certificate CommonName (CN) `Web' does NOT match server name!?
[Fri Aug 12 22:20:35 2011] [notice] Apache/2.2.14 (Ubuntu) mod_ssl/2.2.14 OpenSSL/0.9.8k mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Aug 12 22:20:57 2011] [error] server reached MaxClients setting, consider raising the MaxClients setting

remarque: j'ai créé avant un certificat nommé "Web".

Sinon l'erreur que je site et la seul dans les logs qui semble se rapprocher de mon problème sauf que cet erreur n’apparait pas à chaque tentative de sauvegarde que je fait.

j'ai regardé dans le forum (version anglaise) et j'ai vue des topics sur des problèmes équivalent mais rien qui donne une solution à mon problème.

pouvez vous m'aider? merci d'avance :)

christian

  • Guest
Re: Activer le certificat du serveur Web
« Reply #1 on: August 16, 2011, 11:06:23 am »
Le message, bien que en anglais, est assez clair: il faut que le nom de ton certificat (le CN qui signifie "common name") soit équivalent au nom du serveur. Tu ne peux pas l'appeler "web" sauf si dans ta conf Apache, ton serveur a ce nom.

Alexconquer

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Activer le certificat du serveur Web
« Reply #2 on: August 16, 2011, 01:35:31 pm »
Merci pour ta réponse ^^

peux tu donner plus de détails avec un exemple?

car j'ai testé pas mal de chose avec toujours le même résultat alors que avec Zentyal Beta je ne rencontrais pas se problème.

Alexconquer

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Activer le certificat du serveur Web
« Reply #3 on: August 17, 2011, 11:32:13 am »
j'ai trouvé un topic qui correspond a mon problème...

Quote
http://forum.zentyal.org/index.php/topic,5413.msg22459.html#msg22459

Malheureusement la solution proposé ne fonctionne pas... enfaite elle marche peu être mais je parviens pas à la faire complétement XD

J'ai vraiment du mal a comprendre pourquoi sa bloque, j'ai même plus d'erreur dans les logs mais il ne veut pas activer le certificat quand même >:(