Author Topic: "There wasn't a database connection, check if database exists\n"  (Read 1654 times)

xtrgeo

  • Zen Monk
  • **
  • Posts: 61
  • Karma: +0/-0
    • View Profile
I am moving this here because the support team thinks it might not be a zentyal code bug.

The all story is on ticket 2831 ( http://trac.zentyal.org/ticket/2831 )

The problem on the title comes up when i tried to query the full logs. The techical details is these

Code: [Select]
Trace
There wasn't a database connection, check if database exists\n at /usr/share/perl5/EBox/PgDBEngine.pm line 139
EBox::PgDBEngine::_disconnect('EBox::PgDBEngine=HASH(0x7fa909cf4fa8)') called at /usr/share/perl5/EBox/PgDBEngine.pm line 665
EBox::PgDBEngine::DESTROY('EBox::PgDBEngine=HASH(0x7fa909cf4fa8)') called at /usr/share/perl5/Error.pm line 408
EBox::CGI::Base::run('EBox::CGI::Logs::Index=HASH(0x7fa904fa6a40)') called at /usr/share/perl5/EBox/CGI/Run.pm line 120
EBox::CGI::Run::run('EBox::CGI::Run', 'Logs/Index', 'EBox') called at /usr/share/ebox/cgi/ebox.cgi line 35
ModPerl::ROOT::ModPerl::Registry::usr_share_ebox_cgi_ebox_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7fa904f09b88)') called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 204
eval {...} called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 204
ModPerl::RegistryCooker::run('ModPerl::Registry=HASH(0x7fa904f09f78)') called at /usr/lib/perl5/ModPerl/RegistryCooker.pm line 170
ModPerl::RegistryCooker::default_handler('ModPerl::Registry=HASH(0x7fa904f09f78)') called at /usr/lib/perl5/ModPerl/Registry.pm line 31
ModPerl::Registry::handler('ModPerl::Registry', 'Apache2::RequestRec=SCALAR(0x7fa904f09b88)') called at -e line 0
eval {...} called at -e line 0

I also tried /usr/share/ebox/ebox-create-db but the problem still occurs..

Any idea?

Marcus

  • Forum Moderator
  • Zen Samurai
  • *****
  • Posts: 395
  • Karma: +12/-0
    • View Profile
    • Professional IT Service
Re: "There wasn't a database connection, check if database exists\n"
« Reply #1 on: April 26, 2011, 01:21:26 pm »
Hello,

I stumble on that error few times.  Generally a simple reboot will fix this problem.

In other words, I do suspect an update that didn't properly restart the service.

Have you rebooted since this error showed up ?

Best,

Marcus

xtrgeo

  • Zen Monk
  • **
  • Posts: 61
  • Karma: +0/-0
    • View Profile
Re: "There wasn't a database connection, check if database exists\n"
« Reply #2 on: April 26, 2011, 02:39:24 pm »
Thnks for the reply.

Unfortunately the problem still occurs even after a reboot...

Maybe i am not so lucky! Any other help would be much appreciated...

The message above comes when I query for the full log. When i ask for the summarized i get:

"An internal error has occurred. This is most probably a bug, relevant information can be found in the logs."

Where can i find the logs in order to post it here? It might be useful for u..