Author Topic: Installation problem with file sharing  (Read 2058 times)

justsayclint

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Installation problem with file sharing
« on: September 27, 2008, 05:05:03 am »
Hi everyone,

I am just starting with linux and I was following a step by step guide http://www.howtoforge.com/running-a-file-and-print-server-with-ebox-on-ubuntu8.04-server

I have run into problem very early in the process when I select the "file and sharing" module in the module status area.

When selecting "file sharing" the pop-up displayed and when I pressed "accept" nothing happened for about 10 minutes, as the others had been closing in a matter of seconds I assumed something was wrong and pressed the "X" to close the pop-up. When it closed a tick was there for "file sharing" so I proceeded.

When I pressed "Save Changes" it went throught the modules and then displayed the error:

Quote
Some modules reported error when saving changes . More information on the logs in /var/log/ebox/

Now I cannot add a group as the following error is displayed and trying to add a group does not save.

Quote
An internal error has ocurred. This is most probably a bug, relevant information can be found in the logs.

the line in ebox.log in /var/log/ebox/ which seems to be the error generated when the above is displayed.

Quote
2008/09/26 16:57:58 ERROR> Global.pm:401 EBox::Global::saveAllModules - The following modules failed while saving their changes, their state is unknown: samba

And this error is generated when the I try to add groups:

Quote
2008/09/26 17:18:45 ERROR> Ldap.pm:126 EBox::Ldap::ldapCon - Can't create ldapi connection

I have tried installing samba manually but it didn't seem to make any difference. I tried removing and re-installing ebox too but also that did not help.

Thanks in advance for help you may be able to lend.

Clinton