Author Topic: FTP accounts stop working (Please HELP!)  (Read 2215 times)

leros

  • Zen Monk
  • **
  • Posts: 81
  • Karma: +1/-0
    • View Profile
FTP accounts stop working (Please HELP!)
« on: December 13, 2010, 03:00:56 pm »
Please i need help about FTP, i dont know why ftp accounts stop working but anonymous account work. my configuration is in a slave.
The error i get is:
530 Login incorrect.

but account are correct, i check it on users corner.

in /var/log/syslog i find when i try to login:

Code: [Select]
Dec 13 12:21:03 mail kernel: [ 6420.134289] lo: Disabled Privacy Extensions
Dec 13 12:21:03 mail slapd[15265]: <= bdb_equality_candidates: (uid) not indexed
Dec 13 12:21:03 mail slapd[15265]: <= bdb_equality_candidates: (uid) not indexed
Dec 13 12:21:03 mail vsftpd: pam_ldap: error trying to bind as user "uid=usuario,ou=Users,dc=dominio,dc=com" (Invalid credentials)

Thanks
« Last Edit: December 13, 2010, 05:50:58 pm by leros »

Josep

  • Zen Samurai
  • ****
  • Posts: 255
  • Karma: +6/-0
    • View Profile
Re: FTP accounts stop working (Please HELP!)
« Reply #1 on: December 14, 2010, 09:17:23 am »
Is this a new system?
Do other accesses (Samba/Email/SSH) work?
Looking at the user it is trying to authenticate ("usuario"), seems that you are using a Windows machine with a generic user and trying to access the FTP server directly (but I could be wrong).
In any case, authentication is not working. Because of this, the server assumes that user is a guest/anonymous, and it can access FTP anonymously because you have that option enabled.

exekias

  • Zentyal Staff
  • Zen Warrior
  • *****
  • Posts: 196
  • Karma: +21/-0
    • View Profile
    • The Big Bug Theory
Re: FTP accounts stop working (Please HELP!)
« Reply #2 on: December 14, 2010, 12:44:28 pm »
Hi leros,

Can you try to enable PAM? LDAP opeartion is slightly different if you enable or disable PAM since the last version (on slaves only). Please try it and tell us the result ;)

If this fix your problem we will include a warning message

Thank you for your feedback!

Best regards,
Carlos
« Last Edit: December 14, 2010, 12:54:58 pm by cperez »

leros

  • Zen Monk
  • **
  • Posts: 81
  • Karma: +1/-0
    • View Profile
Re: FTP accounts stop working (SOLVED)
« Reply #3 on: December 14, 2010, 02:28:16 pm »
WOW! that was really easy. Work great!
But i have a doubt, i did touch nothing. There was an update that broke it?

Many thanks!

ccbaxter

  • Zen Apprentice
  • *
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: FTP accounts stop working (Please HELP!)
« Reply #4 on: January 07, 2011, 05:18:53 pm »
OK, that's fine but there is a problem. We can enable PAM if the slave is no acting as PDC so we need a dedicated server for ftp (another one?┬┐). I think it should be a better way of doing this...

Meanwhile i think i'm going to set up a local user just for ftp so being local is the only way to log into the ftp (frustrating).


jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: FTP accounts stop working (Please HELP!)
« Reply #5 on: January 07, 2011, 06:38:09 pm »
This is a limitation of LDAP replication, if you use Samba, you cannot use PAM. We expect to get rid off this in the future though. Patches for fixing that are welcomed as always :)

cl0s

  • Zen Apprentice
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: FTP accounts stop working (Please HELP!)
« Reply #6 on: January 19, 2011, 11:08:08 pm »
HuH? Using Samba & PAM (FTP is also enabled) and working fine.

Maybe this is why I cannot browse through the server though, have to use direct //SERVER/SHARE. I was wondering why browsing stopped working, could very well be the issue.

I do have PDC enabled (because I've been wanting to try it) but we are still using our Windows Server for PDC, Zentyal is just doing some FTP for outside clients and then I've created shares to those /home/client* directory with the specified permissions to those shares for the internal workers that need to use those shares.