Author Topic: [SOLVED]Samba PDC - domain not found  (Read 2489 times)

chessmani

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
[SOLVED]Samba PDC - domain not found
« on: September 20, 2008, 05:24:35 pm »
The scenario is

Kubuntu 8.04
|_Virtualbox 2.02
                 |_Ubuntu Server 8.04
                                                |_ Windows XP

I installed ebox-samba and configured the PDC with domain name ebox.local and roaming profiles enabled. Saved changes.

Afterwards, I created a user called administrator with admin rights for the domain and saved changes.

Once done I enabled the modules networking, userandgroups and samba and saved changes.

I restarted the PC and was able to join the domain. Restarted again and started a new session as administrator.

Just to test everything is allright, I restarted the server and afterwards the Windows XP. Then problems came...

When I logged in with user administrator there was a prompt which said that Windows was unable to load the roaming profile, reason: path not found. I had enabled roaming profiles, so I thought this was not supposed to happen. Then I went to eBox and disabled roaming profiles to see if I could get rid of the notice.

Then, I decided to leave the domain and restarted the XP. After the login I tried to join the domain again and... XP was unable to find the domain. I entered eBox, restarted the modules, disabled/enabled them again with no result.

Any help please?

Thanks in advance.
« Last Edit: September 21, 2008, 01:44:30 am by chessmani »

chessmani

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Samba PDC - domain not found
« Reply #1 on: September 21, 2008, 01:44:09 am »
I solved it... kind of stupid actually. Ubuntu Hardy Server Edition comes with ufw (firewall), which I had enabled. However, I forgot to allow connections to samba... So it was as easy as opening the ports.