Author Topic: squid was not working out of the box  (Read 4118 times)


  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
squid was not working out of the box
« on: January 03, 2008, 11:39:14 pm »
I booted up ebox for the first time last night.  I had pulled the most recent version from the debian repositories.
Code: [Select]
pdc800:~# aptitude show ebox
Package: ebox
State: installed
Automatically installed: no
Version: 0.11
I am running on debian sarge on a xen vm.  Everything as far as the system goes seems to be fine.  This morning when I was trying to impliment the squid feature, I enabled the options while looking over the user documentation and for somereason now matter what I did I could not connect.  I consulted the logs and found...
Code: [Select]
2008/01/03 16:17:28| Starting Squid Cache version 2.5.STABLE9 for i386-debian-linux-gnu...
2008/01/03 16:17:28| Process ID 8666
2008/01/03 16:17:28| With 1024 file descriptors available
2008/01/03 16:17:28| DNS Socket created at, port 1025, FD 5
2008/01/03 16:17:28| Adding nameserver from /etc/resolv.conf
2008/01/03 16:17:28| User-Agent logging is disabled.
2008/01/03 16:17:28| Referer logging is disabled.
2008/01/03 16:17:28| Unlinkd pipe opened on FD 10
2008/01/03 16:17:28| Swap maxSize 102400 KB, estimated 7876 objects
2008/01/03 16:17:28| Target number of buckets: 393
2008/01/03 16:17:28| Using 8192 Store buckets
2008/01/03 16:17:28| Max Mem  size: 102400 KB
2008/01/03 16:17:28| Max Swap size: 102400 KB
2008/01/03 16:17:28| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2008/01/03 16:17:28| /var/spool/squid/00: (2) No such file or directory
FATAL:  Failed to verify one of the swap directories, Check cache.log
        for details.  Run 'squid -z' to create swap directories
        if needed, or if running Squid for the first time.
Squid Cache (Version 2.5.STABLE9): Terminated abnormally.
CPU Usage: 0.010 seconds = 0.010 user + 0.000 sys
Maximum Resident Size: 0 KB

hrmm.. well thankfully the logs were pretty straight forward running
Code: [Select]
squid -zfixed things.  Though to me this seems to me like something that should be run when ebox is installing and configuring squid. 


  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
Re: squid was not working out of the box
« Reply #1 on: January 20, 2008, 04:15:46 pm »
We do that already. However, it seems there are some issues stopping squid and runit during the installation process. When squid can't be stopped, the cache can't be generated. Hopefully, this will be solved in the next release with a newer runit.


  • Zen Apprentice
  • *
  • Posts: 25
  • Karma: +0/-0
    • View Profile
Re: squid was not working out of the box
« Reply #2 on: January 21, 2008, 04:31:47 pm »
Sorry using your thread, but my problem is similar.

I have eBox o.11 running since 20 December, but I think the squid proxy isn't working.

I only have 1% of disk usage (of 220Gb).

I have tried running this commands:

ebox squid stop //squid stopped

squid -z //with unsuccess it says that squid is already running)

ebox squid start //squid started

But I think everything is the same.

I'll appreciate any help.



  • Zen Apprentice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: squid was not working out of the box
« Reply #3 on: January 21, 2008, 05:59:07 pm »
well I am not sure if this is the actual problem(I am not sure what the defaults are) but from a default install of squid proxy the amount of data stored needs to be raised in the default configuration file.

here is my /etc/squid/squid.conf

Code: [Select]

http_port 3128
cache_mem 300 MB
visible_hostname squid800
cache_dir ufs /var/spool/squid 20000 16 256       #the first number represents the amount of           
                                                                           #cache to be stored to disk IE 20000mb or 20GB 

offline_mode on

cache_effective_user proxy
cache_effective_group proxy

maximum_object_size 302400 KB
reload_into_ims off

pipeline_prefetch on

acl malware_block_list url_regex -i "/etc/squid/malware_block_list.txt"
http_access deny malware_block_list

deny_info malware_block_list

acl my_network src
acl all src
http_access allow my_network
http_access deny all