Author Topic: [SOLVED] Zarafa - installed, but problems with web GUI  (Read 5381 times)

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
[SOLVED] Zarafa - installed, but problems with web GUI
« on: August 27, 2010, 08:00:22 pm »
So now I just need to figure out how to get access to the web interface and how to sync addressbook and calendar from Kontact, Thunderbird and mobile devices :-)

I have enabled Zarafa for the relevant users by editing their settings. It should be easier than that! Zarafa should be possible to enable on group level so you do not have to edit each and every user. But I tried editing one of the groups and did not see anything about Zarafa there.

Also, pointing Firefox to http://my.ip.address/webaccess gives me a 404. So what do I do to access the webinterface? I am not using the firewall at all.

I can access the CUPS interface and administrate printers (more about that in a different post).

I get the "It works!" message if I just use the IP address and nothing else.
« Last Edit: August 28, 2010, 12:43:36 am by Oceanwatcher »
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: Zarafa - ebox
« Reply #1 on: August 27, 2010, 10:38:45 pm »
Mobile sync needs z-push which it's not ready yet, will be no later than Monday.

About webaccess, could you paste your ls /etc/apache2/sites-enabled output?

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Zarafa - ebox
« Reply #2 on: August 27, 2010, 11:19:24 pm »
000-default  zarafa-webaccess  zarafa-webaccess-mobile
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Zarafa - ebox
« Reply #3 on: August 27, 2010, 11:20:32 pm »
And the content of zarafa-webaccess:

Code: [Select]
Alias /webaccess /usr/share/zarafa-webaccess

<Directory /usr/share/zarafa-webaccess/>
    DirectoryIndex index.php
    Options -Indexes +FollowSymLinks
    AllowOverride Options

    Order allow,deny
    Allow from all
</Directory>
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Zarafa - ebox
« Reply #4 on: August 27, 2010, 11:31:25 pm »
Everything has been upgraded earlier today, both system and Zentyal.

It is a standalone server and I am trying to access it from my laptop running Kubuntu with Firefox.

Both the server and the laptop is connected via ethernet to the same switch.

Code: [Select]
ii  ebox-antivirus                       1.5.2-0ubuntu1~ppa1~lucid1              eBox - Antivirus
ii  ebox-ca                              1.5.4-0ubuntu1~ppa1~lucid1              Zentyal - Certification Authority
ii  ebox-dhcp                            1.5.4-0ubuntu1~ppa1~lucid1              Zentyal - DHCP Service
ii  ebox-dns                             1.5.1-1ubuntu1~ppa1~lucid1              eBox - DNS Service
ii  ebox-firewall                        1.5.6-0ubuntu1~ppa1~lucid1              Zentyal - Firewall
ii  ebox-ftp                             1.5.2-0ubuntu1~ppa1~lucid1              Zentyal - FTP
ii  ebox-mail                            1.5.5-0ubuntu1~ppa1~lucid1              Zentyal - Mail Service
ii  ebox-monitor                         1.5.6-0ubuntu1~ppa1~lucid1              Zentyal - Monitor
ii  ebox-network                         1.5.8-0ubuntu1~ppa1~lucid1              Zentyal - Network Configuration
ii  ebox-ntp                             1.5.2-0ubuntu1~ppa1~lucid1              Zentyal - NTP Service
ii  ebox-objects                         1.5.1-0ubuntu1~ppa1~lucid1              eBox - Network Objects
ii  ebox-openvpn                         1.5.4-0ubuntu1~ppa1~lucid1              Zentyal - VPN Service
ii  ebox-printers                        1.5.2-0ubuntu1~ppa1~lucid1              Zentyal - Printer Sharing
ii  ebox-remoteservices                  1.5.8-0ubuntu1~ppa1~lucid1              Zentyal - Zentyal Cloud Client
ii  ebox-samba                           1.5.9-0ubuntu1~ppa1~lucid1              Zentyal - File Sharing
ii  ebox-services                        1.5.4-0ubuntu1~ppa1~lucid1              Zentyal - Network Services
ii  ebox-software                        1.5.6-0ubuntu1~ppa1~lucid1              Zentyal - Software Management
ii  ebox-usersandgroups                  1.5.10-0ubuntu1~ppa1~lucid1             Zentyal - Users and Groups
ii  ebox-webserver                       1.5.5-0ubuntu1~ppa1~lucid1              Zentyal - Web Server
ii  ebox-zarafa                          1.5-0ubuntu1~ppa1~lucid1                Zentyal - Groupware (Zarafa)

The last few lines of the ebox.log (just picked some of them - the same blocks repeat over and over):

Code: [Select]
Command output: .
Exit value: 1
2010/08/27 16:12:19 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 16:12:19 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 16:12:40 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 16:12:40 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 16:13:04 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 16:13:04 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 16:17:10 INFO> Service.pm:670 EBox::Module::Service::restartService - Restarting service for module: events
2010/08/27 16:17:14 INFO> EventDaemon.pm:302 EBox::EventDaemon::_loadModules - EBox::Event::Dispatcher::Log loaded from regi$
2010/08/27 16:17:15 INFO> EventDaemon.pm:302 EBox::EventDaemon::_loadModules - EBox::Event::Dispatcher::ControlCenter loaded$
2010/08/27 16:20:22 ERROR> Sudo.pm:214 EBox::Sudo::_rootError - root command cat /var/run/zarafa-gateway.pid failed.
Error output: cat: /var/run/zarafa-gateway.pid: No such file or directory


Exit value: 1
2010/08/27 18:11:59 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:11:59 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:12:21 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:12:21 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:12:44 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:12:44 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:17:07 INFO> Service.pm:670 EBox::Module::Service::restartService - Restarting service for module: events
2010/08/27 18:17:13 INFO> EventDaemon.pm:302 EBox::EventDaemon::_loadModules - EBox::Event::Dispatcher::Log loaded from regi$
2010/08/27 18:17:14 INFO> EventDaemon.pm:302 EBox::EventDaemon::_loadModules - EBox::Event::Dispatcher::ControlCenter loaded$
2010/08/27 18:20:25 ERROR> Sudo.pm:214 EBox::Sudo::_rootError - root command cat /var/run/zarafa-gateway.pid failed.
Error output: cat: /var/run/zarafa-gateway.pid: No such file or directory

Command output:
2010/08/27 18:00:21 ERROR> Sudo.pm:214 EBox::Sudo::_rootError - root command cat /var/run/zarafa-gateway.pid failed.
Error output: cat: /var/run/zarafa-gateway.pid: No such file or directory

Command output: .
Exit value: 1
2010/08/27 18:01:43 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:01:43 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:02:05 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:02:05 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:02:28 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:02:28 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:10:21 ERROR> Sudo.pm:214 EBox::Sudo::_rootError - root command cat /var/run/zarafa-gateway.pid failed.
Error output: cat: /var/run/zarafa-gateway.pid: No such file or directory


Exit value: 1
2010/08/27 18:22:00 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:22:00 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:22:23 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:22:23 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$
2010/08/27 18:22:45 DEBUG> Base.pm:256 EBox::RemoteServices::Base::_queryServicesNameserver - Server mm.internal.ebox-contro$
2010/08/27 18:22:45 ERROR> ebox-notify-job:72 EBox::RemoteServices::Job::Notifier::__ANON__ - Problem with job result notifi$


Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: Zarafa - ebox
« Reply #5 on: August 27, 2010, 11:45:38 pm »
Should be working, did you try with a trailing slash ?

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Zarafa - ebox
« Reply #6 on: August 28, 2010, 12:33:04 am »
Yes. Same problem.

BUT

Tried (again) to re-start webserver in the dashboard, and I got the login :-)

So I now have a log-in for each user.

What about administration of Zarafa? Is there a login for admin? I tried the same login I use to log on to Zentyal and SSH, but it did not work.

I like the layout of Zarafa, but would like to see a slimmer version of some of the graphics. It looks a little cramped on my monitor.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #7 on: August 28, 2010, 10:58:54 am »
Maybe /webaccess-mobile ?

lucaspr

  • Zen Apprentice
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #8 on: August 30, 2010, 08:25:52 pm »
Is sending and receiving mail enabled or not? because I installed the module and it works flawless, but without mail receiving (that is still being delivered to the 'webmail' part, not Zarafa)

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #9 on: August 30, 2010, 09:54:27 pm »
Lucas,

This is a different issue. Please start a new thread as the original problem for this thread is now solved.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

arun

  • Zen Monk
  • **
  • Posts: 86
  • Karma: +0/-0
  • no windows, no gates, all open
    • View Profile
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #10 on: October 09, 2010, 12:24:57 pm »
I am having the same problem.
I have recently loaded Zentyal 2.0, and trying to check the Zarafa.
When pointing http://my.ip.address/webaccess      gives me a 404.

I have restarted the webserver also but not resolved ......
Can anybody help me   ???

Arun

jsalamero

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1419
  • Karma: +45/-1
    • View Profile
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #11 on: October 17, 2010, 12:08:15 pm »
Check /etc/apache2/sites-enabled/ if it's there the Zarafa web configuration file.

cougarmaster

  • Zen Monk
  • **
  • Posts: 80
  • Karma: +0/-0
    • View Profile
Re: [SOLVED] Zarafa - installed, but problems with web GUI
« Reply #12 on: November 06, 2010, 06:19:47 pm »
Hi guys,
    The files zarafa-webaccess zarafa-webaccess-mobile and z-push are in sites-available and not in sites-enabled what do I do to enable it just copy it over and restart webserver?

Tks in advance
Eric