Author Topic: Instalar Zentyal no XenServer 5.6  (Read 3327 times)

Elton_Ferreira

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Instalar Zentyal no XenServer 5.6
« on: September 27, 2010, 03:54:40 pm »
Alguém já tentou instalar o Zentyal 2.0-1 no XenServer 5.6?

Estou tentando fazer funcionar a alguns dias mas ainda sem sucesso.

Instalei o template para Ubuntu 10.04 no Xenserver http://community.citrix.com/display/xs/Installing+Ubuntu+Server+10.04+%2832bit+and+64bit%29+LTS e em seguida efetuei a instalação do Zentyal http://trac.zentyal.org/wiki/Document/Documentation/InstallationGuide ele até instalou porém alguns módulos não funcionam, como por exemplo o modulo webmail, que apresenta erros de conexão com o Banco de Dados.

Obs.: No VMWare ESXi funciona perfeitamente, porem ele é muito limitado e não consigo fazer a migração de maquinas entre hosts a quente, por isto pretendo usar o Citrix XenServer.

Alguém tem ai alguma sugestão para me ajudar?

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Re: Instalar Zentyal no XenServer 5.6
« Reply #1 on: October 13, 2010, 03:17:58 pm »
Elton,

Creio que esteja faltando alguma coisa devido ao fato de vc não estar usando o instalador/iso original do Zentyal... Será que vc não pode fazer a instalação usando a ISO do Zentyal?

PS: Quando usei o Xen Server, tive problemas para acessoao Shell de uma máquina remota (quando usando NAT)... Tipo, a partir do meu endereço 200.x.x.x eu conseguia acessar o Shell via console... Mas Se eu tivesse em minha máquina, 10.x.x.x, isto não era possível... Vc já passou por este problema? Hoje uso VMware ESXi quando preciso virtualizar o ambiente...

Abraços,
Jorge Quintão

dmeireles

  • Zen Monk
  • **
  • Posts: 51
  • Karma: +1/-0
  • Masturbation, the human version of autoexec.bat
    • View Profile
Re: Instalar Zentyal no XenServer 5.6
« Reply #2 on: October 13, 2010, 04:59:55 pm »
Bem, vim aqui parar em busca de uma appliance de zentyal para xen, mas niente :( existe uma forma de colocar o ubuntu (10.04) a funcionar paravirtualizado em Xen, mas nao é oficialmente suportado e nao sei se permite instalar o zentyal. De qualquer forma, vou brincar um pouco com este script a ver se consigo personalizar a coisa de forma a funcionar com o zentyal. Stay tunned...

http://community.citrix.com/display/xs/Installing+Ubuntu+Server+10.04+(32bit+and+64bit)+LTS

:: EDIT ::

Elton, a nao ser q se consiga colocar o zentyal a correr em modo paravirtualizado (i.e., como correm as VMs Linux suportadas no XenServer) nao vais conseguir migrar. A funcao de migracao requer que as xenserver tools sejam instaladas, e isso só é possivel em modo paravirtualizado.
« Last Edit: October 13, 2010, 05:05:22 pm by dmeireles »

Elton_Ferreira

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Instalar Zentyal no XenServer 5.6
« Reply #3 on: October 14, 2010, 01:03:43 am »
Obrigado pelas dicas,

Eu consegui fazer o Zentyal funcionar, instalando primeiramente o Ubuntu através do script que coloquei no post anterior, e em seguida efetuei a instalação do Zentyal através dos repositórios, porem alguns módulos não funcionam corretamente.

Tenho dois hosts idênticos com Dell PowerEdge 2950, e consigo migrar as maquinas a quente perfeitamente através do XenTools.

Atualmente estou usando o Zentyal somente como servidor FTP no ambiente virtualizado, pois ainda não tive tempo de continuar os testes para colocar os outros módulos para funcionar nele, assim que conseguir algo novo posto aqui.

Mas acredito que o caminho é instalar o Zentyal através dos repositórios, devido ao suporte ao Ubunto 10.04 no Xenserver, eu ate tentei instalar usando a ISO porem ele apresenta vários erros e estive pesquisando no site da Citrix, os erros são relacionados ao suporte ao sistema de arquivos.

Abraços.



dmeireles

  • Zen Monk
  • **
  • Posts: 51
  • Karma: +1/-0
  • Masturbation, the human version of autoexec.bat
    • View Profile
Re: Instalar Zentyal no XenServer 5.6
« Reply #4 on: October 14, 2010, 01:19:54 am »
É do sistema de arquivos sim porque o ubuntu usa por padrão ext4 mas o xen em modo virtualizado requer q,pelo menos a partição de boot seja ext3