Author Topic: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0  (Read 2855 times)

jbejr

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Olá a todos! Instalei recentemente a versão 2.0 do Zentyal, e me deparei com um problema que não ocorria na versão 1.4 do ebox. Quando eu seleciono a opção "Autorizar e filtrar" dentro da configuração de Proxy HTTP, a autenticação (e, por conseguinte, a navegação) das máquina clientes não funciona. Já com a política "Autorizar e permitir", sem problemas.

Isso já ocorreu com mais alguém? Alguém sabe como consertar isso?


Agradeço, desde já, a atenção.

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #1 on: September 02, 2010, 07:09:17 pm »
Amigo,

A opcao do deu navegador de detectar as configuracoes automaticamente devem estar marcadas.

Caso elas estejam marcadas e mesmo assim nao funcione tente por o proxy na mao, veja se ele pede autenticacao.

A opcao de proxy transparente nao pode estar marcada!


Ping o host wpad e veja se seu zentyal responde.

jbejr

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #2 on: September 02, 2010, 07:28:33 pm »
Obrigado pela ajuda!


O servidor proxy já está adicionado manualmente no navegador, e a opção de proxy transparente não está selecionada, conforme a documentação oficial do sistema já indica que o protocolo não suporta ambos simultaneamente.

Se eu marco a opção "Autorizar e permitir" no servidor, a autenticação e a navegação funcionam uma beleza, mas se eu marco a opção "Autorizar e filtrar", para de funcionar a autenticação (o navegador fica esperando resposta do servidor por um bom tempo pra depois dar timeout...

O ping funciona normalmente para qualquer endereço a partir do servidor ou das estações clientes...

Será que é um bug do sistema?

Valeu!

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #3 on: September 02, 2010, 08:35:40 pm »
Estranho mesmo! Vou colocar aqui no meu pra testar, te digo jaja.

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #4 on: September 02, 2010, 08:50:55 pm »
Quando coloquei autorizar e filtrar, todos navegaram normalmente. Ele nao pediu senha.
Entao fui la e coloquei o proxy na mao e ele abriu a caixa pedindo usuario e senha.

Desabilite o antivirus nos perfis do proxy e teste.

jbejr

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #5 on: September 02, 2010, 09:05:57 pm »
Tentei reinstalar o servidor, para eliminar a possibilidade de ser uma gafe minha, mas nada feito. Mesmo na máquina recém-instalada o problema persistiu...

Fiz o teste, desmarcando o antivirus no perfil default (é o único que está disponível). Também não deu certo, o problema persiste...  :-\

No arquivo /var/log/auth.log percebi que existem alguns erros relacionados ao pam_auth, mas não sei do que se trata ou se tem relação com o problema...

Muito estranho!

Valeu!

jbejr

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #6 on: September 02, 2010, 09:27:39 pm »
Descobri o problema!

Mais ou menos uma "burrada" minha, mas fica a resposta pra ninguém cair no mesmo erro!  :D

A minha máquina está configurada como um gateway/dhcp/firewal/proxy. Ela possui um IP externo, e cria uma subrede (192.168.x.x). Ao fornecer o endereço do proxy para o navegador da máquina cliente, eu estava colocando o ip externo (esse era o erro, afinal de contas pelo firewall eu havia bloqueado qualquer tráfego que não passasse pela porta do proxy "192.168.0.1:3128"). Então, a máquina cliente não conseguia navegar porque não conseguia achar o endereço fornecido! (Oooops!).

Muito obrigado pela atenção, e desculpem o incômodo!

marcelhalls

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
Re: Proxy não funciona com opção "Autorizar e filtrar" no Zentyal 2.0
« Reply #7 on: September 02, 2010, 09:33:25 pm »
Mude o topico como resolvido.