Author Topic: basic ldap setting  (Read 1094 times)

snarf77

  • Zen Apprentice
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
basic ldap setting
« on: August 30, 2010, 01:36:43 pm »
Hi all,

I plan to install SOGo and make it work together with EBox. Before, because I'm really a total beginner with LDAP, I'm trying to understand a little bit better ldap setting and the way it is managed by EBox.

To do that I installed GQ software (I'm running an ubuntu  10.04) to externally connect to my ebox ldap but I can't succeed to connect to my ldap directory. To start, I just wanted to browse for the users I add in users and groups module.

So my basic questions are:
    what kind of authentification should  I set  ? I guess SASL but using the password given in LDAP settings page of EBox does not allow me to connect.
    I just configured the BaseDN in GQ being the one I saw in EBox. Am I missing something else ?

PS:
  - firewall has been set to authorise ldap port.
  - I can't find any logs for ldap module in EBox, is there somewhere I can check to help troublshooting ?
Thank you for helping me





snarf77

  • Zen Apprentice
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: basic ldap setting
« Reply #1 on: August 30, 2010, 04:59:32 pm »
Or has anyone be granted connection with ldapsearch tools to the ebox ldap server...

whatever the tool, I still got (from syslog on the ebox server)

Aug 30 16:55:01 portal CRON[13386]: (root) CMD (/usr/share/ebox-usersandgroups/slave-sync)
Aug 30 16:55:01 portal slapd[3670]: connection_read(24): no connection!
Aug 30 16:55:01 portal slapd[3670]: connection_read(24): no connection!
Aug 30 16:55:01 portal slapd[3670]: connection_read(26): no connection!


PS: ldapsearch is working fine locally, it is only when I use it from another machine with:
ldapsearch -H ldap://192.168.1.200 -b cn=portal

that I get this error. What could be wrong ? SASL, bad user/login...

please help

snarf77

  • Zen Apprentice
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: basic ldap setting
« Reply #2 on: September 01, 2010, 12:13:10 pm »
None to give a little help ??