Author Topic: New beta installer available: eBox Platform 1.5-1  (Read 4635 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
New beta installer available: eBox Platform 1.5-1
« on: August 05, 2010, 10:50:17 am »
Hi fellow eBox users,

The development team of eBox Platform, the Linux small business server, is glad to announce the availability of a new installer CD for the eBox Platform 1.5 series including the improvements and fixes that have been done since the first 1.5 installer. You can download the new installer, as usual, from our Downloads page.

eBox Platform 1.5-1 is a development version based on Ubuntu 10.04 and it will become eBox Platform 2.0 (next stable release) after a stabilization period. As you know, we have now finished with the development of new features and from now on we will focus all our attention (with your help!) on testing, bugfixing and optimizing the software.

The most relevant changes on this new 1.5-1 installer are focused on improving the performance:

- We have replaced the old configuration backend (gconf) with a brand new one based in redis. This improves the user experience in general, making the web interface more responsive. It also decreases the installation and boot times.
- The migration scripts of each package are now run on the same perl interpreter, this reduces the installation time of the packages.

This is an important change and we need your feedback to check that everything is right. There shouldn't be any problem on a fresh install, but if you upgrade from an older version with the configuration stored in gconf there may be issues in the migration process.

It also includes new versions of the following modules: Users, DHCP, Backup, Groupware, Firewall, IDS, Monitor, NTP, Software Management, HTTP Proxy and Webserver. They can be also updated via the Software Management module if you already have a installed 1.5 system.

Please remember that the 1.5 versions are beta and not intended for production environments. Having said that, we would appreciate greatly your help in testing this version and making the eBox 2.0 a great release!
Zentyal Server Lead Developer

zonique

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: New beta installer available: eBox Platform 1.5-1
« Reply #1 on: August 05, 2010, 10:01:22 pm »
Thanks for the update. I've just upgraded my 1.5 system and everything seems to work perfectly.
Kudos to the development team!

ctek

  • Zen Warrior
  • ***
  • Posts: 197
  • Karma: +6/-1
    • View Profile
Re: New beta installer available: eBox Platform 1.5-1
« Reply #2 on: August 06, 2010, 12:02:03 am »
good news about the new installer
I've just updated the mirror  :)
For those interested http://www.acp-it.ro/index.php?c=download&lng=_en

Keep it up and best regards.
Bogdan

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: New beta installer available: eBox Platform 1.5-1
« Reply #3 on: August 06, 2010, 05:16:00 am »
This is the announcement section of the forum, other than commenting the announcement itself, please add your comments in the appropriate forum sections. Everything that has to do with v. 1.5 of eBox goes in the Beta section.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

satyris

  • Zen Monk
  • **
  • Posts: 94
  • Karma: +0/-0
    • View Profile
Re: New beta installer available: eBox Platform 1.5-1
« Reply #4 on: August 06, 2010, 07:55:32 am »
Is there an upgrade possiblity from 1.4 to 1.5.1 ?

Dont want to install everything again, just to test it.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: New beta installer available: eBox Platform 1.5-1
« Reply #5 on: August 07, 2010, 08:11:01 pm »
Is there an upgrade possiblity from 1.4 to 1.5.1 ?

Dont want to install everything again, just to test it.

Probably, just changing the repositories in /etc/apt/sources.list to point to lucid and eBox 1.5 instead of hardy and 1.4 and executing: apt-get update && apt-get dist-upgrade

But this hasn't been tested so I don't recommend you to do it in production environments.
Zentyal Server Lead Developer