Author Topic: Zentyal's Samba 4.11 not compatible with AD 2012R2 for some reason?  (Read 136 times)

averyfreeman

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Hi,

According to specs on the Samba Wiki, Samba 4.11 should be compatible with Active Directory 2012R2 by default: https://wiki.samba.org/index.php/Windows_2012_Server_compatibility#Joining_Samba_as_a_domain_member_to_a_Windows_domain

Quote
From Samba 4.11, our default schema is 2012 R2. Prior to Samba 4.11, our default schema was 2008 R2. For those running 2008 R2 schema and want to upgrade to 2012 R2 schema, you may run the 'samba-tool domain schemaupgrade' command.

However, if I try to join my AD domain, which is 2012R2, using Zentyal Developer 7.0, it shows an error that it's only compatible with AD 2008 or earlier.

What's the reason for this discrepancy?  Is there a way I can circumvent it?  AFAIK I cannot downgrade further than 2012R2 on my AD controllers.

turalyon

  • Zen Apprentice
  • *
  • Posts: 42
  • Karma: +11/-0
    • View Profile
Re: Zentyal's Samba 4.11 not compatible with AD 2012R2 for some reason?
« Reply #1 on: November 22, 2021, 03:05:05 pm »
I think is because of this:

* https://wiki.samba.org/index.php/Joining_a_Windows_Server_2012_/_2012_R2_DC_to_a_Samba_AD

--

“This world is ours, and by the Holy Light we will keep it safe, now and forever"