Author Topic: Complete idiot here, please help!  (Read 3080 times)

ztxdk

  • Guest
Complete idiot here, please help!
« on: June 15, 2008, 11:31:24 pm »
Hi!

I'm apparently a complete idiot. I've installed the ebox/ubuntu-server from the site. And it runs fine.
In the machine I have two network cards, one connected to the internet via a adsl modem, and the other to my own network.

How do I get the internal machines to access the internet? I can't get passed the ebox machine.. And I can't find out how to set the thing up..

my goal is to use the ebox instead of my crappy old router...

Maritn

sixstone

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1417
  • Karma: +26/-0
    • View Profile
    • Sixstone's blog
Re: Complete idiot here, please help!
« Reply #1 on: June 16, 2008, 09:49:11 am »
Hi there!

Once you set up one interface as external (ADSL modem one) and the other one as internal (your own network).  In order to allow Web traffic, you may create a "web" services in Services and you may set 80/tcp and 443/tcp as destination ports. Aftewards, you may go to Firewall -> Packet Filter and set the rules in "Filtering rules for internal networks" section allowing "web" service from "any" service.

If you're using Ubuntu version, don't forget to enable firewall and network modules.

Hope this helps.
My secret is my silence...

ztxdk

  • Guest
Re: Complete idiot here, please help!
« Reply #2 on: June 16, 2008, 01:15:36 pm »
I will try that later today, but what about gateways?
What should the setup be... Can't figure it out..

sixstone

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1417
  • Karma: +26/-0
    • View Profile
    • Sixstone's blog
Re: Complete idiot here, please help!
« Reply #3 on: June 16, 2008, 08:03:36 pm »
You may set the modem ADSL as your default gateway. To do so, you must set up a gateway in Network -> Gateways with the IP address you have set up before to your modem ADSL. As well as default option as clicked.

If you're going to use traffic shaping, set correct values to your connection to the gateway, if it is not just make them up.

I hope this helps.
My secret is my silence...

ztxdk

  • Guest
Re: Complete idiot here, please help!
« Reply #4 on: June 16, 2008, 08:26:49 pm »
yeah, got me a lot futher. Now i'm connecting via the ebox machine. Seems to work now..
But now another problem came up.

I have a process amavisd-new (as far as I can't see it's for the mail filter/scanner) using a lot of cpu, even tough all the mail modules are switched off... (dont need that function yet..)

Martin   

javi

  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
Re: Complete idiot here, please help!
« Reply #5 on: June 16, 2008, 10:31:26 pm »
Hi Martin,

On the current eBox version, if you don't enable a module, you are telling eBox  not to manage the service. That's why amavis is running even though the modules are disabled.

In the past the working mode wasn't the same. It worked as follows:if  the module was disabled the associated services wouldn't be running.

This change was caused for a few modifications we had to make to comply with the ubuntu policy.

We are already working on approach that will allow you to stop the service if you are not using it while still complying with the above requirements.

As a temporary workaround you can manually stop the services you are not using. For example to stop amavis:

Code: [Select]
/etc/init.d/amavis stop
Don't hesitate to ask us if you need further help :)


ztxdk

  • Guest
Re: Complete idiot here, please help!
« Reply #6 on: June 17, 2008, 09:04:41 pm »
Ok, cool..

I tried to shut down the amavisd via terminal but it kept comming back.. But after 15-20 minutes it stopped and has given me no problems after that..

I have a few more questions if you don't mind:

1. is the firewall somehow blocking avahi-daemon? I need mdns on the lan because some of my machines are macs and the filesharing works alot better with mdns... I've installed it and its running but none of my machines can see the ebox via mdns.

2. If i install a printer manually (my printers are not in the list of printers in ebox) does it show up in ebox interface or just in cups'?

Martin

javi

  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
Re: Complete idiot here, please help!
« Reply #7 on: July 07, 2008, 12:57:38 pm »
Sorry for the delay :)

Quote
1. is the firewall somehow blocking avahi-daemon? I need mdns on the lan because some of my machines are macs and the filesharing works alot better with mdns... I've installed it and its running but none of my machines can see the ebox via mdns.

Yeah, that's totally possible. Add a service with the ports using avahi-daemon, add the firewal rules and you are done :)

Quote
2. If i install a printer manually (my printers are not in the list of printers in ebox) does it show up in ebox interface or just in cups'?

I'm sorry to say that not, it won't show up in eBox. But you can still access them via cups...