Author Topic: Mail modules available for eBox 1.5!  (Read 3156 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Mail modules available for eBox 1.5!
« on: June 02, 2010, 04:50:26 pm »
We are glad to announce that the following modules have been added to our 1.5 repository:

- mail
- mailfilter
- webmail

Now 1.5 is almost complete, the only three modules missing are egroupware, asterisk and l7-protocols.

Remember that 1.5 is a beta version, don't hesitate to let us know any bug or problem you encounter. Your feedback is really welcome.

For more information about installing packages, please read the following:

http://trac.ebox-platform.com/wiki/Document/Documentation/InstallationGuide#eBoxPlatform1.5packages
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Mail modules available for eBox 1.5!
« Reply #1 on: June 03, 2010, 12:44:31 am »
egroupware (1.6.003) is also available!
Zentyal Server Lead Developer

JuanjoA

  • Zen Monk
  • **
  • Posts: 79
  • Karma: +0/-0
    • View Profile
Re: Mail modules available for eBox 1.5!
« Reply #2 on: June 03, 2010, 01:31:16 pm »
Great Work!!!

Thx for your efforts!

Juanjo A.

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Mail modules available for eBox 1.5!
« Reply #3 on: June 03, 2010, 10:43:38 pm »
I am making the jump to 1.5 on my home server :-)

This is the guide I am following for the Ubuntu server upgrade:

https://help.ubuntu.com/community/LucidUpgrades

There is a section about "Network Upgrade for Ubuntu Servers (Recommended)" there.

I added the eBox 1.5 ppa first as described here:

http://trac.ebox-platform.com/wiki/Document/Documentation/InstallationGuide#eBoxPlatform1.5packages

But I have a feeling it got disabled during the upgrade. In that case, I will just enable it after restart of the server and do the eBox upgrade. Looking forward to have a "new" server and to be able to participate in bughunting.

I am also looking forward to get the apt cache going on the server! This should really be a part of the standard install of eBox - it REALLY helps when you have more than one Linux system in the house...
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

flashbios

  • Zen Apprentice
  • *
  • Posts: 36
  • Karma: +0/-0
    • View Profile
    • Electronics, Bioschip & WebDesign services
Re: Mail modules available for eBox 1.5!
« Reply #4 on: June 04, 2010, 12:32:18 am »
Good work !!!!!!!!!!!!!!!!!!!!!

I have left ClearOS (Clarkconnect) now totally, Ebox is really getting great !

Looking forward to a 64bits Ebox system !!!

And maybe a CLOUD of EBOX servers ????

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Mail modules available for eBox 1.5!
« Reply #5 on: June 04, 2010, 05:29:56 am »
As expected, the eBox ppa got disabled during the 8.04 to 10.04 upgrade. It has become standard now to disable all 3rd party repositories during upgrade, and you have to go back to the sources.list to manually enable them again (they are just commented out).

This resulted in a lot of errors during the upgrade. I think it could have been a good thing to "deactivate" eBox before this upgrade, then upgrade 8.04 to 10.04, then upgrade all eBox components and then re-enable eBox.

I enabled the eBox ppa again, did an apt-get update and apt-get upgrade. Now we will have to see how that goes :-) A few more rounds of this with restarts between each one should get me closer to the goal.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Mail modules available for eBox 1.5!
« Reply #6 on: June 04, 2010, 05:55:33 am »
A scary thing - sudo apt-get autoremove seem to delete A LOT of things that eBox uses! After this command, eBox is not working. So I am going to install all packages and see what happens.

Before this, I connected briefly to the web interface, and I can definitely say this: 1.5 is A LOT more responsive than 1.4.x!!

I could not get into users and groups. There was a problem with LDAP, so I probably do not have it configured correctly. Something got messed up in the upgrade.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Mail modules available for eBox 1.5!
« Reply #7 on: June 04, 2010, 06:33:56 am »
A very weird thing:

I tried to issue

sudo apt-get install ebox-all

and got a "can not find package"

Same with ebox-office.

So I issued sudo apt-get install ebox-samba and it kicked in and also listed a ton of dependencies. After ok, it is now installing and some things were obviously missing as it is being downloaded

During the installation/configuration network and users (because of ldapi problems) failed.

I am going through the list of packages now and installing them one by one as none of the profile packages seems to work.
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

christian

  • Guest
Re: Mail modules available for eBox 1.5!
« Reply #8 on: June 04, 2010, 07:41:26 am »
Oceanwatcher,

I did what you're currently doing, that is to upgrade to eBox 1.5.
To make the story accurate, I also upgraded from Hardy to Lucid  ;D

Well, few expected detail like source.list to be updated but this aside, upgrades when rather fine.
I made the OS upgrade some weeks ago, before mail module was available and deployed my own postfix configuration.
Then I happily installed mail, webmail etc... modules once available and starting from this point I faced some problems.

But I believe we should discuss this in another thread, not in the announcement section isn't it?

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Mail modules available for eBox 1.5!
« Reply #9 on: June 04, 2010, 07:44:55 am »
Sure, I'll start a new thread.

Done here:

http://forum.ebox-platform.com/index.php?topic=3906.new#new
« Last Edit: June 04, 2010, 07:58:39 am by Oceanwatcher »
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here