Author Topic: Five more eBox 1.5 modules available for Ubuntu 10.04  (Read 7301 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Five more eBox 1.5 modules available for Ubuntu 10.04
« on: May 18, 2010, 03:03:24 am »
We are glad to announce that the following modules have been added to our 1.5 repository

- monitor
- trafficshaping
- ids
- software
- webserver

We hope to have the rest of the packages ported to 1.5 by the end of the month.

Remember that 1.5 is a beta version, don't hesitate to let us know any bug or problem you encounter. Your feedback is really welcome.

For more information about installing packages, please read the following:

http://trac.ebox-platform.com/wiki/Document/Documentation/InstallationGuide#eBoxPlatform1.5packages
Zentyal Server Lead Developer

Svein Wisnaes

  • Zen Samurai
  • ****
  • Posts: 325
  • Karma: +5/-0
  • A Norwegian living in Brazil
    • View Profile
    • Oceanwatcher Media | Svein Wisnaes
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #1 on: May 18, 2010, 09:27:41 pm »
I still can not find any guide on how to update from 1.4 to 1.5 - It would be good to give a step-by-step guide for this.

Would it be best to look at it as a straight Ubuntu Server upgrade first and upgrade the base system, then add the repository and do the upgrade of eBox? Or is it better to add the eBox ppa for 1.5 first and then do the whole upgrade?

I appreciate that you do not recommend running 1.5 in a production environment. But if we should have any chance of helping you with 1.5 we need to have it installed. And upgrading is part of this, so we might as well do it and report any problems.

My server here at home is OK to test it on. It will be a bit of work if the installation is borked, but I will manage :-)
Regards,

Oceanwatcher
Do NOT use PM for support. This is a community forum and support is not on a one-on-one basis.
READ BEFORE POSTING - How to make a good post - click here

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #2 on: May 18, 2010, 10:08:56 pm »
1.5 is not a stable version, there is no guarantee the update will work without problems, we hope to have updates without problem from 1.4 to 2.0

Anyway, if you can try, you only have to change the repositories in /etc/apt/sources.list (both eBox and ubuntu 8.04 to 10.04 ones) and execute:

apt-get update
apt-get dist-upgrade

But do it at your own risk... Furthermore, not all the modules are available on 1.5 yet.
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #3 on: May 20, 2010, 08:18:21 pm »
I've just published two more packages: ebox-ebackup and ebox-antivirus
Zentyal Server Lead Developer

ArchWill

  • Zen Apprentice
  • *
  • Posts: 33
  • Karma: +0/-0
    • View Profile
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #4 on: May 21, 2010, 08:26:21 pm »
At this point, what's missing?

Arch

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #5 on: May 21, 2010, 11:59:11 pm »
The missing packages are: asterisk, egroupware, jabber, l7-protocols, mail, mailfilter, radius, remoteservices and webmail.

We hope to have them ready in the next days.
Zentyal Server Lead Developer

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #6 on: May 23, 2010, 08:01:36 pm »
jabber and radius are also ready now :)
Zentyal Server Lead Developer

christian

  • Guest
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #7 on: May 25, 2010, 07:45:40 am »
well... fine but looking at this page:
http://trac.ebox-platform.com/wiki/Document/Documentation/InstallationGuide#eBoxPlatform1.5packages

it looks a bit missleading.

this one is not available:
https://trac.ebox-platform.com/wiki/Document/Announcement/1.5

and looking at first link mixing information about 1.4 and 1.5, it's a bit difficult to guess what is and what is not available for 1.5  :(   1.4 runs on 8.04 only and 1.5 (I know it's "test" version) not covering services I need (i.e. there is no mail), maybe it's worth to wait for 2.0

So, for the time being, I'll revert back to manual postfix+dovecot+squirrelmail config and will have a look later.
BTW, I did the same for my platform running Samba because I've not been able to deal with LDAP master/slave config.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #8 on: May 25, 2010, 08:32:48 am »
The link to the 1.5 announcement was wrong, it should be http instead of https, it is fixed now. Thanks for reporting it.

As I said, the missing packages like ebox-mail will be available in the next days.

You can also check what's available in 1.5 here:

https://launchpad.net/~ebox/+archive/1.5
Zentyal Server Lead Developer

ctek

  • Zen Warrior
  • ***
  • Posts: 197
  • Karma: +6/-1
    • View Profile
Re: Five more eBox 1.5 modules available for Ubuntu 10.04
« Reply #9 on: May 26, 2010, 10:34:03 pm »
GOOD WORK! Best regards and keep it up. On behalf of all the users we are grateful of all the hard work that you guys at eBox are doing ! Thank you !

Best regards
Bogdan.