Author Topic: [SOLVED?] SOGo 5.5.1 not working after upgrade to Zentyal 8 (from 7)  (Read 574 times)

ggallo

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Dear All!

This is my first post on this forum. I registered to share an experience with you, maybe it will be useful for someone else.

Last weekend I moved and upgraded a Zentyal system for one of our customers. The original VM was on VMware ESXi 6.5 and the new server runs Proxmox 8. The original Zentyal system was on 5.0.14...

I moved the VM with ovftool to the new server, comverted with qm importovf. First experinece is that the VM boots up but no console ouptut at all on the Proxmox virtual console. The sulution was editing the boot line in grub at boot time, removing "quiet splash..." from the linux line. Then the console showed up.

After configuring the newtork (of course, Ethernet adapter name differs on Proxmox), I realised that I need to configure the network on the web admin. Only manually configuring it in /etc/network/interfaces lost at reboot. After this, the gateway must be deleted and added again (to replace the interface name), also on the web admin.

After correcting the network and gateway, the upgrades from 5.0.14 to 6.0 -> 6.1 -> 6.2 -> 7.0 -> 7.1 went basically flawlessly to my surprise. I did everything by the book (a.k.a Zentyal 8.0 version upgrade page), so I checked all the things between every upgrade and rebooted the VM after each, then checked the services after each reboot.

Somewhere in the upgrades, some services (like mysql) got disabled, and because of this not started at boot. But this shows up relatively quickly, and enablig, starting sthose solve these problems.

After upgrading from 7.1 to 8.0, basically everything worked, but SOGo and antivirus modules. The antivirus module was easy, the /etc/systemd/system/clamav-daemon.service.d/extend.conf file was renamed on an upgrade, and /run/clamav folder was not created and configured for clamav daemon. After renaming back and restarting clamav-daemon and antivirus module, the service worked as expected.

The SOGo thing was much harder. The login screen showed up as plain text, without formatting and without any buttons, etc. No css, js, images get downloaded from the server. The SOGo system is a black box, very hard to debug what happens (or not happens). I searched the internet for hours at dawn to finally figure out that the SOGo version 5.0 which was used in Zentyal 5.0 to 7.1 has the necessary css/img/js/fonts files in /usr/lib/GNUstep/SOGo/WebServerResources but SOGo version 5.5.1 (which came with Ubuntu 22.04/Zentyal 8.0) put these files in /usr/share/GNUstep/SOGo/WebServerResources. Maybe this causes the problem.
To test this theory, I simply symlinked all 4 folders to the "old" place, restared sogo service and everything started working again!

I don't know why this happened. I archived all upgrade console messages on all upgrades and found noting erronous about SOGo upgrades in these logs. I found nothing about this folder change on the internet, found none occurence of this problem documented (yet). But maybe someone out there experience the same in the future when upgrading to Zentyal 8, and this is a solution for it.

The [SOLVED?] tag means that the problem solved, but I think this is not a proper solution for it. It needs investigation any maybe some actions on the upgrade scipts (on Zentyal side or on SOGo packaging side).

Daniel Joven

  • Zentyal Staff
  • Zen Monk
  • *****
  • Posts: 69
  • Karma: +21/-0
    • View Profile
Re: [SOLVED?] SOGo 5.5.1 not working after upgrade to Zentyal 8 (from 7)
« Reply #1 on: June 28, 2024, 10:35:51 am »
Hi ggallo,

First of all, thank you for the detailed explanation of your upgrade process from the very old Zentyal 5 version.

About the MySQL issue, we thought it was fixed with the below function in the script but apparently, it does not cover all the cases. Do you remember if this issue caused the upgrade to fail?

* https://github.com/zentyal/zentyal/blob/7.1/main/core/src/scripts/release-upgrade#L352

Regarding ClamAV and Sogo, as you found out, it looks like it is an issue caused by the version of Zentyal you upgraded from. However, we are going to do some tests in our internal lab and if it is necessary, we will update the script, the documentation, or both.

Again, thank you for sharing.

Best regards, Daniel Joven.