Author Topic: [SOLVED] Error when updating from version 7.0.9 to version 7.1  (Read 1166 times)

Gabriel GHEORGHIU

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
    • Managed Services Provider for IT&C Infrastructure
[SOLVED] Error when updating from version 7.0.9 to version 7.1
« on: September 14, 2023, 08:55:19 am »
Please help me to solve the following error that occurred during the update process:

Code: [Select]
ns1admin@ns1:~$ sudo bash -x /usr/share/zentyal/release-upgrade
...........................
+ echo -e '\033[0;32m Preparing the Zentyal upgrade from 7.0 to 7.1...\033[0m'
 Preparing the Zentyal upgrade from 7.0 to 7.1...
+ echo

+ getIDSRepositoryKey
+ echo -e '\033[0;32m - Getting the repository key for IDS module...\033[0m'
 - Getting the repository key for IDS module...
+ gpg --keyserver keyserver.ubuntu.com --recv-keys D7F87B2966EB736F
gpg: keyserver receive failed: Connection timed out
+ gpg --export D7F87B2966EB736F
gpg: WARNING: nothing exported
+ gpg --batch --yes --delete-keys D7F87B2966EB736F
gpg: key "D7F87B2966EB736F" not found: Not found
gpg: D7F87B2966EB736F: delete key failed: Not found
+ '[' -f /etc/apt/trusted.gpg.d/suricata.gpg ']'
++ stat -c %s /etc/apt/trusted.gpg.d/suricata.gpg
+ '[' 0 -lt 340 ']'
+ echo -e '\033[0;31m - The IDS key could not download correctly...\033[0m'
 - The IDS key could not download correctly...
+ echo

+ exit 130
ns1admin@ns1:
« Last Edit: September 14, 2023, 12:59:32 pm by Gabriel GHEORGHIU »

Daniel Joven

  • Zentyal Staff
  • Zen Monk
  • *****
  • Posts: 53
  • Karma: +21/-0
    • View Profile
Re: Error when updating from version 7.0.9 to version 7.1
« Reply #1 on: September 14, 2023, 11:58:19 am »
Hi Gabriel,

It seems that the connection to the server ‘keyserver.ubuntu.com’ was not successful (time-out), and because of that, the script could not fetch the public key and ended up in failure.

Probably there was a temporal issue in that server when you ran the upgrade. We have checked the command that failed and it works now, so, the server is recovered.

We strongly recommend you check the Internet resolution in your Zentyal 7.0 server before trying to upgrade the server again.

Best regards, Daniel Joven.

Gabriel GHEORGHIU

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
    • Managed Services Provider for IT&C Infrastructure
Re: Error when updating from version 7.0.9 to version 7.1
« Reply #2 on: September 14, 2023, 12:59:00 pm »
Hi Daniel,

Thanks for the reply!
I use Zentyal as the Authoritative DNS Server for my domain.
The server is placed in the DMZ, with a private IP address.
In UTM I have two policies created:
Inbound: Port forwarding WAN IP to DMZ IP TCP+UDP/53
Outgoing: TCP+UDP/53, TCP+UDP/123, ICMP8, ICMP30, TCP43, 80,443.
Do we still need an open port for everything to work properly?

The update worked without problems after I opened all ports in UTM for both Inbound and Outcoming.

Is it necessary to upgrade the Ubuntu version (from version 20.04.6 LTS to 22.04.3 LTS)?

Code: [Select]
Using username "ns1admin".
ns1admin@10.0.10.10's password:
Welcome to Ubuntu 20.04.6 LTS (GNU/Linux 5.4.0-162-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage



You can access the Zentyal Web Interface at:

 * https://your_server_ip:8443



Expanded Security Maintenance for Applications is not enabled.

0 updates can be applied immediately.

5 additional security updates can be applied with ESM Apps.
Learn more about enabling ESM Apps service at https://ubuntu.com/esm

New release '22.04.3 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Thu Sep 14 13:00:43 2023 from 192.168.168.151
ns1admin@ns1:~$



Thanks in advance for your help!
Best regards,
Gabriel
« Last Edit: September 14, 2023, 02:07:02 pm by Gabriel GHEORGHIU »

Daniel Joven

  • Zentyal Staff
  • Zen Monk
  • *****
  • Posts: 53
  • Karma: +21/-0
    • View Profile
Re: [SOLVED] Error when updating from version 7.0.9 to version 7.1
« Reply #3 on: September 15, 2023, 12:12:28 pm »
Hi Gabriel,

Glad to hear that the upgrade worked correctly.

Regarding your question, no, you cannot upgrade to Ubuntu 22.04, just ignore that message. Zentyal 7.0 and 7.1 are based on Ubuntu 20.04.

Best regards, Daniel Joven.

Gabriel GHEORGHIU

  • Zen Apprentice
  • *
  • Posts: 26
  • Karma: +1/-0
    • View Profile
    • Managed Services Provider for IT&C Infrastructure
Re: [SOLVED] Error when updating from version 7.0.9 to version 7.1
« Reply #4 on: September 15, 2023, 12:24:37 pm »
Hi Daniel,

OK! I will not upgrade Ubuntu.
Thank you again!

If I don't mind, regarding the ports that must be opened if Zentyal is placed in the DMZ, can you give me some advice?

TIA,
Gabriel