Author Topic: Zentyal 7.0 DHCP error  (Read 1499 times)


  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Zentyal 7.0 DHCP error
« on: January 08, 2022, 06:21:24 am »
Server is working fine, but on dashboard it says DHCP module installed incorrectly.   run command
sudo dpkg --configure -a to correct.

Tried running command but still have errer.   Tried restarting program.

The network is currently using the DHCP server from the ROUTER, so it's not necessary, but I don't even see it as an option to configurer / enable or disable.



  • Zen Warrior
  • ***
  • Posts: 197
  • Karma: +15/-0
    • View Profile
Re: Zentyal 7.0 DHCP error
« Reply #1 on: January 18, 2022, 04:41:32 pm »

First of all, you need to check the status of the package 'zentyal-dhcp':

Code: [Select]
sudo dpkg -l zentyal-dhcp

Then, I recommend you to check if there is other package that is broken:

Code: [Select]
sudo dpkg -l | egrep -v '^ii'

In case you have any broken package, you can try to fix them with the following command:

Code: [Select]
sudo dpkg --configure -a

If the issue persists, then, analyze the following log files in order to get any information about the error:

* /var/log/zentyal/zentyal.log
* /var/log/syslog
* /var/log/dpkg.log
* /var/log/apt/

Also, you should check the disk space:

Code: [Select]
df -h

furthermore, you should take a look at apparmor, perhaps it is causing you the issue with this module.

Code: [Select]
sudo systemctl status apparmor

Hope it helps.


“This world is ours, and by the Holy Light we will keep it safe, now and forever"