Poll

Why Sieve does not work in Zentyal 7.0

1
0 (0%)
2
0 (0%)

Total Members Voted: 0

Author Topic: Zentyal 7.0 Sogo-Sieve dont work  (Read 266 times)

AkustikProjekt

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Zentyal 7.0 Sogo-Sieve dont work
« on: August 15, 2021, 08:30:26 pm »
Hi,

I installed a new Zentyal 7.0 server as a mail server, but Sogo-Sieve does not work. Sieve is activated in the Zentyal web interface, I created the rule in Sogo, but Sieve just doesn't work. Does anyone have a tip why this can be?

BR
Christian

half_life

  • Bug Hunter
  • Zen Hero
  • *****
  • Posts: 866
  • Karma: +59/-0
    • View Profile
Re: Zentyal 7.0 Sogo-Sieve dont work
« Reply #1 on: August 21, 2021, 06:50:16 pm »
I can tell you that you are not alone.  I am seeing the same behavior post upgrade to 7.0.   I see the following in the logs:
Code: [Select]
Aug 21 06:25:12 zentyal5 dovecot: lda(REDACTED)<696063><wtQXKpjiIGH/ngoAX2jQnA>: Error: sieve: Failed to initialize script execution: Invalid postmaster_address: invalid address `postmaster' specified for the postmaster_address setting


I don't have a root cause or a solution yet.

Daniel Joven

  • Zentyal Staff
  • Zen Apprentice
  • *****
  • Posts: 31
  • Karma: +19/-0
    • View Profile
Re: Zentyal 7.0 Sogo-Sieve dont work
« Reply #2 on: August 23, 2021, 10:53:29 am »
Hi,

This behaviour is a bug reported, below you have the ticket. Until Developers Team fix it, you can set a valid email address to the postmaster box in the Zentyal Admin Interface.

* https://github.com/zentyal/zentyal/issues/2067

Best regards, Daniel Joven.

half_life

  • Bug Hunter
  • Zen Hero
  • *****
  • Posts: 866
  • Karma: +59/-0
    • View Profile
Re: Zentyal 7.0 Sogo-Sieve dont work
« Reply #3 on: September 02, 2021, 03:59:53 am »
Confirmed.  Overriding the postmaster email address to an existing address fixed the errors and the filters now work as before. 

Thanks