Author Topic: [RESOLVIDO] Problema ao adicionar controle de acesso ao diretório  (Read 545 times)

soeirorenan

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Galera, estou passando por um problema ao adicionar o controle de acesso (ACL) a um diretório no Zentyal 6.2 Community Edition.

Na hora de escolher Usuário ou Grupo ele simplesmente não puxa esses valores, ou seja fica desabilitada a opção de Usuário/Grupo. Dessa forma não consigo adicionar nenhum controle.

Alguém já passou por esse problema? Gostaria de saber se teria como adicionar as ACLs via terminal também.

Segue link da imagem: https://postimg.cc/8FkQfVwH
« Last Edit: April 22, 2021, 05:14:38 am by soeirorenan »

soeirorenan

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Re: Problema ao adicionar controle de acesso ao diretório
« Reply #1 on: April 22, 2021, 05:13:30 am »
Encontrei o problema. Acontece que aqui para evitar que os usuários movessem os diretórios de um lado para o outro eu adicionei o atributo +i (imutable) aos diretórios compartilhados com o comando:

Code: [Select]
chattr +i /home/samba/shares/*
Acontece que quando o modulo vai iniciar ele tenta setar o chown desses diretórios, e como suas propriedades estão bloqueadas o módulo samba do Zentyal não consegue iniciar. Devido a isso não consigo fazer as edições no webadmin.

A solução foi remover esses atributos e reiniciar o módulo samba do Zentyal.

Code: [Select]
chattr -i /home/samba/shares/*
zs samba restart