Author Topic: after upgrading to 7.0 some modules will not start  (Read 147 times)

kcurtis

  • Zen Apprentice
  • *
  • Posts: 41
  • Karma: +5/-0
    • View Profile
after upgrading to 7.0 some modules will not start
« on: March 26, 2021, 01:41:44 pm »
I issued the upgrade to 7.0 from my 6.2 server. After the reboot it does not seem to be working. I have no web interface. When I putty in and try # zs restart there are a few error in stopping but when it starts the services the following fail;
network
ca
samba
mail
webadmin

If I try to start them I am getting
Code: [Select]
root@zdomain:/home/protel# zs samba start
 * Restarting Zentyal module: samba                                                                                                [fail]
Invalid value for Default login shell: /usr/bin/bash.
Choose a value within the value set: /bin/rbash, /bin/sh, /usr/bin/screen, /bin/bash, /bin/dash

Is there anything I can do to fix this?





WarrenShort

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: after upgrading to 7.0 some modules will not start
« Reply #1 on: March 26, 2021, 01:58:15 pm »
Ohh man, i have the same problem. If i will find how to fix it, i will write!
« Last Edit: March 27, 2021, 07:15:52 pm by WarrenShort »

kcurtis

  • Zen Apprentice
  • *
  • Posts: 41
  • Karma: +5/-0
    • View Profile
Re: after upgrading to 7.0 some modules will not start
« Reply #2 on: March 26, 2021, 03:11:50 pm »
Does anyone know where the backups are saved on the server? I think I need to do download the last one (that I did NOT copy off the server) so I can restore to a fresh install

ggowins

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +5/-0
    • View Profile
Re: after upgrading to 7.0 some modules will not start
« Reply #3 on: March 26, 2021, 03:50:24 pm »
They should be in /var/lib/zentyal/conf/backups/


Daniel Joven

  • Zentyal Staff
  • Zen Apprentice
  • *****
  • Posts: 21
  • Karma: +13/-0
    • View Profile
Re: after upgrading to 7.0 some modules will not start
« Reply #4 on: March 29, 2021, 12:29:48 pm »
Hi,

This issue is answered in the following post (reply 1 and 4):

* https://forum.zentyal.org/index.php/topic,35173.0.html

Best regards, Daniel Joven.