Author Topic: Upgrade from Zentyal 6.2 to 7.0 is now available  (Read 2407 times)

jrtaylor

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +6/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #30 on: April 01, 2021, 10:46:45 pm »
Still trying to upgrade a system that was installed 6.0 and upgraded to 6.2.x with no problems. I cloned the system and have attempted to upgrade to 7. After a bit I reboot and get stuff like this in the logs.

Code: [Select]
Apr  1 15:32:10 mx1 systemd[1]: Reloading.
Apr  1 15:32:10 mx1 systemd[1]: /lib/systemd/system/dbus.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/dbus/system_bus_socket → /run/dbus/system_bus_socket; please update the unit file accordingly.
Apr  1 15:32:10 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  1 15:32:10 mx1 systemd[1]: /lib/systemd/system/dovecot.service:19: PIDFile= references a path below legacy directory /var/run/, updating /var/run/dovecot/master.pid → /run/dovecot/master.pid; please update the unit file accordingly.
Apr  1 15:32:20 mx1 systemd[1]: Reloading.
Apr  1 15:32:20 mx1 systemd[1]: /lib/systemd/system/dbus.socket:5: ListenStream= references a path below legacy directory /var/run/, updating /var/run/dbus/system_bus_socket → /run/dbus/system_bus_socket; please update the unit file accordingly.
Apr  1 15:32:20 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  1 15:32:20 mx1 systemd[1]: /lib/systemd/system/dovecot.service:19: PIDFile= references a path below legacy directory /var/run/, updating /var/run/dovecot/master.pid → /run/dovecot/master.pid; please update the unit file accordingly.


erotavlas

  • Zen Apprentice
  • *
  • Posts: 35
  • Karma: +8/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #31 on: April 06, 2021, 06:11:26 pm »
Hi,
I have two machines with zentyal 6.2 and I have the offer on the web gui to upgrade to zentyal 7.0, however the process gets stuck on preparing. On both machines I have zentyal core 6.2.3, on web gui there is 6.2.8 suggestion (it redirects to doc page), but I cannot update it even via command line.
Any idea?
Thank you

You have to upgrade to 6.2.8 before attempting to upgrade to 7.0. Make sure you have a backup or snapshot before attempting an upgrade.

Right, but I cannot do it. I was able to upgrade up to 6.2.4 as you can see https://postimg.cc/qzh702G1.

jrtaylor

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +6/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #32 on: April 08, 2021, 05:33:27 am »
One big thing that I want to note here is that the IDS/IPS system seems to block some of the upgrade. After turning it off almost ALL my problems went away!!! The only thing I still see are these messages.

Code: [Select]
Apr  7 22:31:25 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  7 22:31:26 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  7 22:31:26 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  7 22:31:27 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  7 22:31:28 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.
Apr  7 22:31:31 mx1 systemd[1]: named.service: Wants dependency dropin /etc/systemd/system/named.service.wants/fix-744304.conf is not a symlink, ignoring.


Mr. Crux

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +2/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #33 on: April 23, 2021, 12:51:29 pm »
We try to upgrade from 6.2.9. As Daniel Joven suggested we run the script itself to upgrade the system by executing the command:
Code: [Select]
sudo bash -x /usr/share/zentyal/release-upgrade
Could not upload an execution output here; download link https://gofile.io/d/y16VhA
Noticeable errors start line 4842, then at line 5015

/var/log/mysql/error.log - https://gofile.io/d/fHM5jd
« Last Edit: April 26, 2021, 09:35:49 am by Mr. Crux »

Mr. Crux

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +2/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #34 on: April 23, 2021, 01:17:28 pm »
Hi,
I have two machines with zentyal 6.2 and I have the offer on the web gui to upgrade to zentyal 7.0, however the process gets stuck on preparing. On both machines I have zentyal core 6.2.3, on web gui there is 6.2.8 suggestion (it redirects to doc page), but I cannot update it even via command line.
Any idea?
Thank you

You have to upgrade to 6.2.8 before attempting to upgrade to 7.0. Make sure you have a backup or snapshot before attempting an upgrade.

Right, but I cannot do it. I was able to upgrade up to 6.2.4 as you can see https://postimg.cc/qzh702G1.

Had the same issue. Check if it is related to Expired APT (GPG) Key (webmaster's msg)

erotavlas

  • Zen Apprentice
  • *
  • Posts: 35
  • Karma: +8/-0
    • View Profile
Re: Upgrade from Zentyal 6.2 to 7.0 is now available
« Reply #35 on: April 24, 2021, 05:29:02 pm »
Hi,
I have two machines with zentyal 6.2 and I have the offer on the web gui to upgrade to zentyal 7.0, however the process gets stuck on preparing. On both machines I have zentyal core 6.2.3, on web gui there is 6.2.8 suggestion (it redirects to doc page), but I cannot update it even via command line.
Any idea?
Thank you

You have to upgrade to 6.2.8 before attempting to upgrade to 7.0. Make sure you have a backup or snapshot before attempting an upgrade.

Right, but I cannot do it. I was able to upgrade up to 6.2.4 as you can see https://postimg.cc/qzh702G1.

Had the same issue. Check if it is related to Expired APT (GPG) Key (webmaster's msg)

It worked, thank you. Now I installed the version 6.2.9 and I can upgrade to 7.0.x.