Author Topic: 6.2.6 reboot causes 504 gateway timeout  (Read 454 times)

Bozoputer

  • Zen Apprentice
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
6.2.6 reboot causes 504 gateway timeout
« on: February 28, 2021, 09:44:01 pm »
The issue is any reboot or cold boot causes the web interface to timeout with 504 Gateway timeout.  I am running this in a VM and can restore to a previous snapshot to reproduce this.  The last update was to 6.2.6 in January and I had rebooted after that, though only once.  There were no other updates since. 

/var/log/zentyal/error.log
Quote
2021/02/15 16:21:52 [error] 2830#2830: *28 upstream prematurely closed connection while reading response header from upstream, client: IPREMOVED, server: , request: "POST /SysInfo/Controller/Halt HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock:", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/SysInfo/View/Halt"
2021/02/15 16:47:57 [error] 2827#2827: *49 open() "/usr/share/zentyal/www/images/package-icons/zentyal-ucp.png" failed (2: No such file or directory), client: IPREMOVED, server: , request: "GET /data/images/package-icons/zentyal-ucp.png HTTP/1.1", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Software/EBox"
2021/02/15 16:50:11 [error] 2827#2827: *241 open() "/usr/share/zentyal/www/images/package-icons/zentyal-ucp.png" failed (2: No such file or directory), client: IPREMOVED, server: , request: "GET /data/images/package-icons/zentyal-ucp.png HTTP/1.1", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Software/EBox"
2021/02/22 09:39:18 [error] 2808#2808: *9 open() "/usr/share/zentyal/www/images/package-icons/zentyal-ucp.png" failed (2: No such file or directory), client: IPREMOVED, server: , request: "GET /data/images/package-icons/zentyal-ucp.png HTTP/1.1", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Software/EBox"
2021/02/28 14:05:20 [error] 2834#2834: *38 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=network&widget=interfaces HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"
2021/02/28 14:05:20 [error] 2832#2832: *35 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=general HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"
2021/02/28 14:05:20 [error] 2834#2834: *37 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=links HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"
2021/02/28 14:05:20 [error] 2834#2834: *36 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=dhcp&widget=dhcpleases HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"
2021/02/28 14:05:20 [error] 2832#2832: *34 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=processes HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"
2021/02/28 14:05:20 [error] 2832#2832: *33 upstream timed out (110: Connection timed out) while reading response header from upstream, client: IPREMOVED, server: , request: "GET /Dashboard/WidgetJSON?module=sysinfo&widget=modules HTTP/1.1", upstream: "uwsgi://unix:///run/zentyal-webadmin/webadmin.sock", host: "IPREMOVED:8443", referrer: "https://IPREMOVED:8443/Dashboard/Index"


Yes the mentioned png file is missing. 

I am not versed in NGINX enough to the determine what is going other than The Google has told me that the focus is on the 110 connection timeout and suggest proxy adjustments.  I am not running the Zentyal proxy, but this could be (yet another) proxy reference. 


/var/log/zentyal/zenytal.log
Quote
2021/02/28 14:00:34 INFO> Service.pm:965 EBox::Module::Service::restartService - Restarting service for module: webadmin
2021/02/28 14:00:36 INFO> Init.pm:90 EBox::Util::Init::start - Start modules finished
2021/02/28 14:00:41 ERROR> Sudo.pm:240 EBox::Sudo::_rootError - root command LANG=C /usr/sbin/ejabberdctl status failed.
2021/02/28 14:00:42 ERROR> Service.pm:80 EBox::Service::running - No such daemon: samba-ad-dc at No such daemon: samba-ad-dc at /usr/share/perl5/EBox/Service.pm line 80
2021/02/28 14:01:10 ERROR> Sudo.pm:240 EBox::Sudo::_rootError - root command LANG=C /usr/sbin/ejabberdctl status failed.
2021/02/28 14:01:10 ERROR> Service.pm:80 EBox::Service::running - No such daemon: samba-ad-dc at No such daemon: samba-ad-dc at /usr/share/perl5/EBox/Service.pm line 80
2021/02/28 14:01:40 ERROR> Sudo.pm:240 EBox::Sudo::_rootError - root command LANG=C /usr/sbin/ejabberdctl status failed.
2021/02/28 14:01:40 ERROR> Service.pm:80 EBox::Service::running - No such daemon: samba-ad-dc at No such daemon: samba-ad-dc at /usr/share/perl5/EBox/Service.pm line 80
2021/02/28 14:02:00 ERROR> Sudo.pm:240 EBox::Sudo::_rootError - root command LANG=C /usr/sbin/ejabberdctl status failed.
2021/02/28 14:02:00 ERROR> Service.pm:80 EBox::Service::running - No such daemon: samba-ad-dc at No such daemon: samba-ad-dc at /usr/share/perl5/EBox/Service.pm line 80

Only found 1 related reference and it was for a install of 5.09 and related to Anti-virus.  The solution does not seem to apply to me. 


Any assistance would be appreciated. 

Thanks in advance.