Author Topic: Migracion Windows Server 2008R2, no funcionan compartidas  (Read 681 times)

gose

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Migracion Windows Server 2008R2, no funcionan compartidas
« on: February 01, 2021, 12:57:10 pm »
Hola a todos!
 Llevo peleándome bastantes dias con esto y no le veo solución...

Tenemos un Windows Server 2008R2 como controlador de dominio y queremos pasarlo a Zentyan ante la venida de Windows 10 a todos los puestos, he conseguido migrar los roles bien, he probado en Zentyal 6.2 y en Zentyal 7.0, con algunos problemas pero conseguido.

He instalado Zentyal asi como 7 u 8 veces haciendo pruebas de traspado de roles y de lo siguiente.

El problema viene con las compartidas, los usuarios están todos con sus grupos, pero al crear las compartidas, me dejó hacer un par de usuarios y luego deja de "permitirlo", la secuencia es: creo una compartida, voy a permisos y alli selecciono Usuario o Grupo, pues cuando ya no deja hacerlo, ya no aparece ni el desplegable de usuarios, esta en gris, como si no hubiera usuarios, y hay muchos usuarios!

 He probado de todo pero no hay manera, con los grupos lo mismo, otro problema es que a los dos usuarios que me ha permitido hacer, cuando entro desde un windows a las supuestas carpetas con permisos, no me deja entrar, vamos que no hay permisos o no se los da, y he leido algo de darle permisos de administrador, pero eso no se puede hacer con los usuarios.

¿ Alguna idea de por donde puedo tirar?

 Ante la desesperación he instalado una versión desde cero de Zentyal 7.0 y he comenzado a crear usuarios y carpetas compartidas para ver si asi me deja hacerlo, suponiendo que el problema pueda ser que el traspaso desde Windows Server deja por ahi restos "raros".

Gracias!!!

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Migracion Windows Server 2008R2, no funcionan compartidas
« Reply #1 on: February 01, 2021, 01:45:13 pm »
 :)

¿Has comprobado que samba está habilitado y funcionando cuando encuentras estos errores?

Comprueba el estado de la base de datos de samba:

Code: [Select]
sudo samba-tool dbcheck --cross-ncs -v
Si encuentras errores, puedes utilizar el comando anterior con las opciones "--fix" y "--yes" para intentar "repararlo".

¿Has comprobado si hubo errores durante el proceso de unión de Zentyal al dominio como controlador de dominio adicional?

¡Salud!

PS: No deberías haber transferido los roles FSMO antes de estar seguro de que el nuevo controlador de dominio funciona correctamente.
« Last Edit: February 01, 2021, 01:46:49 pm by doncamilo »
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

gose

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Migracion Windows Server 2008R2, no funcionan compartidas
« Reply #2 on: February 14, 2021, 11:11:26 pm »
Hola,
 A ver... a todo esto decir que estoy con máquinas virtuales, hice copia para trabajo en local mientras todavia resiste el Windows Server 2008R2, pero la idea es cambiarlo.

 Hice todo el proceso sin errores, Zentyal se une como dominio adicional, una vez hecho esto, puedo crear usuarios en cada uno y automáticamente aparece en el otro, el controlador de dominio veo que funciona correctamente, por lo que procedo a traspasar los roles FSMO, que también todo correcto, apago el Windows Server y toma Zentyal el control, me uno a dominio y tambien funciona correctamente.

 Bueno a todo esto ahora no puede desunirme de dominio, ya ha probado de todo y siempre da un error al intentar salirse:
Error al intentar desunirse del dominio "XXXXX.XXXXX"
  "No se puede encontrar el modulo especificado"

 Todo el problema ahora son las carpetas compartidas, y es raro porque a veces funcionan, a veces no.

 Incluso borré todos los grupos importados de Windows Server y empiezo a hacerlos uno por uno, probando a ver, en una de estas veo que puedo hacerlo desde:

Usuarios y Equipos
  Grupos
    Elegir grupos
       Directorio compartido para este grupo
   
Seleccionado "Grupo de Seguridad), al darle añadir, me salta un error:   "Grupo no tiene valores seleccionables"
Lo raro es que hago click en "Grupo de Seguridad" aunque YA ESTA SELECCIONADO, vuelvo a darle AÑADIR y entonces me dice: Share de grupo añadida

Hecho esto voy a un Windows, me logueo (estoy en dominio), voy a \\192.168.1.11 ,  me aparece la carpeta creada, pero intento entrar y no me deja, me salta error "Windows no puede tener acceso a \\192..."

Bueno a todo esto guardando cambios cada vez que lo pide, incluso me deslogueo de windows y vuelvo a entrar.

Voy a hace un grupo que ya existia pero que borré para comenzar de nuevo, es el de Prensa, me salta un error:
Nombre de cuenta ya existente: Prensa (CN=Carlos Perez Perez,OU=Usuarios,DC=domain,DC=local).
Y no puedo crear este grupo, no lo entiendo.

Creo 2 grupos, meto en el grupo a un administrador, guardo cambios, voy a "Compartición de Ficheros", creo carpeta bajo Zentyal, doy permisos a esos 2 grupos, guardo cambios, vuelvo a windows, me logueo y voy a compartidos, aparece pero no me deja entrar, ni siquiera puedo entrar en la carpeta compartida del propio usuario que crea por defecto!!!

Curiosamente puedo entrar en otra carpeta a la que le di permisos de "Admins de Dominio", muy raro todo, hay veces en Zentyal que entré y en los permisos ACL, no aparecia nada en usuarios ni en grupos, ergo no podia seleccionar nada.

A ver unas ayuditas para ver por donde puedo tirar, que me quiero escapar de Win lo que pueda!!!  X-DD

Gracias