Author Topic: Elemento não encontrado  (Read 754 times)

carlossimao

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Elemento não encontrado
« on: January 27, 2021, 11:23:39 am »
Olá!

Configurei o Zentyal 6.2 como AD e DC, ingressei o computador win10 e win7 no domínio com sucesso.
No Zentyal criei a pasta compartilhada e consedi suas respctivas permissões de acesso.
Quando vou na estação e entro no caminho \\dominiot.lan me é listado a pasta reservada ao usuário que estou logado e todas as pastas compartilhadas.
Quando tento abrir uma pasta que o usuário logado não tem acesso abre o pop-up para informar as credenciais de outro usuário que tenha permissões. O que é correto.
Quando tento abrir a pasta destinada ao usuário logado ou uma pasta compartilhada que ele tenha permissão, aparece o erro:

Abrir pasta

\\dominiot.lan\usuario.logado não está acessível. Talvez você não tenha permissões para usar este recurso de rede. Contate o administrador deste servidor para saber se você tem permissões de acesso.

Elemento não encontrado.

O interessante é que se eu mapear qualquer uma das pastas que o usuário tem acesso, consigo acessar normalmente pela unidade mapeada.

Alguém já passou por isso?

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Elemento não encontrado
« Reply #1 on: January 27, 2021, 02:02:45 pm »
:)

Se bem entendi, este não é um comportamento normal.

Ainda assim, os diretórios "iniciais" do usuário no servidor não são iguais aos recursos compartilhados.

Eles podem ser configurados pelo samba mesmo como "somente leitura" e "não navegáveis" (execute o comando sudo testparm em seu servidor e consulte a seção "casas")

Esses diretórios não são os mesmos que hospedam os "perfis de roaming" de cada usuário, se habilitados. Eles são os mesmos que as "casas" das contas do servidor local e são necessários se o módulo PAM estiver habilitado (o que permite usar as contas de domínio como contas locais no servidor)

(O módulo FTP também tem uma opção que permite que você dê aos usuários acesso às suas casas, mas é até certo ponto uma anomalia)

Verifique se o diretório /home/user.registered existe em seu servidor e execute estes comandos para obter informações:

Code: [Select]
getfacl /home/user.registered
sudo testparm
net rpc share list localhost -User.registered% password

Use smbclient para tentar acessar a pasta:

Code: [Select]
smbclient //10.5.12.107/test -User.registered% password

Saúde!

PS: Que Camões perdoe o Google Translate e a mim por esse ataque à nobre língua portuguesa. : P
« Last Edit: January 27, 2021, 02:10:25 pm by doncamilo »
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

carlossimao

  • Zen Apprentice
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Re: Elemento não encontrado
« Reply #2 on: January 28, 2021, 01:40:43 pm »
:)

Se bem entendi, este não é um comportamento normal.

Ainda assim, os diretórios "iniciais" do usuário no servidor não são iguais aos recursos compartilhados.

Eles podem ser configurados pelo samba mesmo como "somente leitura" e "não navegáveis" (execute o comando sudo testparm em seu servidor e consulte a seção "casas")

Esses diretórios não são os mesmos que hospedam os "perfis de roaming" de cada usuário, se habilitados. Eles são os mesmos que as "casas" das contas do servidor local e são necessários se o módulo PAM estiver habilitado (o que permite usar as contas de domínio como contas locais no servidor)

(O módulo FTP também tem uma opção que permite que você dê aos usuários acesso às suas casas, mas é até certo ponto uma anomalia)

Verifique se o diretório /home/user.registered existe em seu servidor e execute estes comandos para obter informações:

Code: [Select]
getfacl /home/user.registered
sudo testparm
net rpc share list localhost -User.registered% password

Use smbclient para tentar acessar a pasta:

Code: [Select]
smbclient //10.5.12.107/test -User.registered% password

Saúde!

PS: Que Camões perdoe o Google Translate e a mim por esse ataque à nobre língua portuguesa. : P

Olá.

Muito obrigado pela contribuição.
Investiguei melhor e realmente não consegui acessar o compartilhamento pelo caminho \\dominiot.lan e sim pelo caminho \\NetBIOS ou \\IP do Servidor

Não entendi bem este comportamento, mas resolvi meu problema.

 ;D

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Elemento não encontrado
« Reply #3 on: January 28, 2021, 04:00:52 pm »
 :)

Hmmm ...  :o...  ;D...  ;)

Você deve usar o FQDN do controlador de domínio e não apenas o nome do domínio.

Ou seja, tente este URI:

Code: [Select]
//hostname.domainname.tld/user.name

Saúde!
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,