Author Topic: Update 4.0 -> 5.0: HowTo verfügbar?  (Read 332 times)

Lueghi

  • Zen Monk
  • **
  • Posts: 89
  • Karma: +1/-0
    • View Profile
Update 4.0 -> 5.0: HowTo verfügbar?
« on: December 29, 2020, 12:08:20 pm »
Hallo Zentyal-Freunde,
gibt es so etwas wie ein HowTo das die besonderen Stolperfallen aufzeigt und Lösungen wie man sie umschiffen kann? Ein direktes Update aus des System heraus läuft bei mir auf einen Fehler?
[edit]Link auf Fehlerbeitrag ergänzt[/edit]
« Last Edit: December 29, 2020, 04:32:43 pm by Lueghi »
Lueghi
--------------
still on Zentyal 4.0 (but testing update to 6.2) with samba, DNS, DHCP, Webserver, SoGo and VPN-server in my little home-network

Lueghi

  • Zen Monk
  • **
  • Posts: 89
  • Karma: +1/-0
    • View Profile
Re: Update 4.0 -> 5.0: HowTo verfügbar?
« Reply #1 on: January 08, 2021, 01:00:08 pm »
Da ich im englischsprachigen Teil keine Hilfe bekommen habe, versuche ich das Problem hier auch noch mal zu schildern in der Hoffnung auf Hilfe:
Ich versuche gerade, meinen Server von Version 4.0 auf 6.2 zu aktualisieren. Ich habe die Updates in einer virtuellen Maschine getestet (allerdings nur mit einer Zentyal-Grundkonfiguration). Das Update von 4.0 auf 5.0 hat ohne Probleme funktioniert. Jetzt bekomme ich bei meinem realen Server eine Fehlermeldung laut Samba:
Code: [Select]
Die folgenden Pakete haben unerfüllte Abhängigkeiten :
 zentyal-samba : Hängt ab von: samba (>= 2:4.6.7+dfsg-1), sollte aber nicht installiert werden
                 Hängt ab von: samba-vfs-modules, sollte aber nicht installiert werden
                 Hängt ab von: samba-dsdb-modules, sollte aber nicht installiert werden
                 Hängt ab von: winbind, sollte aber nicht installiert werden
                 Hängt ab von: libnss-winbind, sollte aber nicht installiert werden
                 Hängt ab von: libpam-winbind, sollte aber nicht installiert werden
E: Probleme können nicht behoben werden, Sie haben fehlerhafte Pakete behalten.
Download fehlgeschlagen, erneuter Versuch in 5 Sekunden...

Die Ausgabe von apt-cache unmet samba:
Code: [Select]
Paket samba Version 3:4.1.17+dfsg-1~zentyal5 hat eine unerfüllte Abhängigkeit:
 Ersetzt: libsamdb0 (< 4.0.0~alpha17~)
 Ersetzt: libsamdb0:i386 (< 4.0.0~alpha17~)
 Ersetzt: python-samba (< 2:4.1.4+dfsg-3)
 Ersetzt: python-samba:i386 (< 2:4.1.4+dfsg-3)
 Ersetzt: samba-ad-dc
 Ersetzt: samba-ad-dc:i386
 Ersetzt: samba-common (<= 2.0.5a-2)
 Ersetzt: samba-common:i386 (<= 2.0.5a-2)
 Ersetzt: samba-doc (< 2:4.0.5~)
 Ersetzt: samba-doc:i386 (< 2:4.0.5~)
 Ersetzt: samba-libs (< 2:4.1.4+dfsg-2)
 Ersetzt: samba-libs:i386 (< 2:4.1.4+dfsg-2)
 Ersetzt: samba4 (< 3:4.1.13)
 Ersetzt: samba4:i386 (< 3:4.1.13)
Es sieht für mich so aus, dass das System einige Abhängigkeiten zu samba von zentyal5 hat.
Meine Frage ist also: Was kann ich tun, um dieses Problem zu beheben? Welche zusätzlichen Informationen benötigt ihr, um mir einen Tipp zu geben?

Habe noch einige zusätzliche Test gemacht. Ausgabe von  dpkg -l | samba:
Code: [Select]
adminuser@zentyal1 12:52 ~ > dpkg -l | grep samba
ii  libsamba-perl                         0.11+2~8                                   amd64        Perl bindings for samba 4.0
ii  python-samba                          3:4.1.17+dfsg-1~zentyal5                   amd64        Python bindings for Samba
ii  samba                                 3:4.1.17+dfsg-1~zentyal5                   amd64        SMB/CIFS file, print, and login server for Unix
ii  samba-common                          3:4.1.17+dfsg-1~zentyal5                   all          common files used by both the Samba server and client
ii  samba-common-bin                      3:4.1.17+dfsg-1~zentyal5                   amd64        Samba common files used by both the server and the client
ii  samba-dsdb-modules                    3:4.1.17+dfsg-1~zentyal5                   amd64        Samba Directory Services Database
ii  samba-libs:amd64                      3:4.1.17+dfsg-1~zentyal5                   amd64        Samba core libraries
ii  samba-vfs-modules                     3:4.1.17+dfsg-1~zentyal5                   amd64        Samba Virtual FileSystem plugins
ii  zentyal-samba                         4.0.11                                     all          Zentyal - Domain Controller and File Sharing
adminuser@zentyal1 21:56 ~ >
Für mich scheint es so, dass es einen erfolglosen Versuch gab, zentyal5 zu installieren. Dies muss vor langer Zeit geschehen sein, weil ich mich nicht daran erinnern kann :(. Und mein aktuelles System mit zentyal 4.0 funktioniert seit Jahren einwandfrei. Meine Frage ist also, ob ich richtig liege: wenn ich die Samba-Teile von *zentyal5* entfernen kann, wird das "normale" Upgrade wieder funktionieren. Aber wie kann ich die kaputten zentyal5-Abhängigkeiten entfernen? Ich bin kein Linux-Guru, aber ich kann die Kommandozeile verwenden.

Lueghi
--------------
still on Zentyal 4.0 (but testing update to 6.2) with samba, DNS, DHCP, Webserver, SoGo and VPN-server in my little home-network