Author Topic: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS  (Read 1302 times)

nkeseci

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« on: November 19, 2020, 10:50:55 am »
Hello!
I know I shouldn't have upgraded before zentyal posted new release but I made a mistake  :(
I upgraded to Ubuntu 20.04 LTS while running Ubuntu 18.04 LTS and Zentyal 6.2 as Domain Controller and File Sharing without any problem.
Only zentyal-samba can not be installed due to its dependencies:
Code: [Select]
...
The following packages have unmet dependencies:
 zentyal-samba : Depends: libauthen-krb5-easy-perl but it is not installable
...
Unable to downgrade Ubuntu. I think a fresh install Zentyal 6.2 will be required. Does anyone have any other advice to run Zentyal 6.2 with Ubuntu 20.04.
Thanks in advance,

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #1 on: November 20, 2020, 03:53:24 pm »
 :P

Each one of the Zentyal versión is bounded to one Ubuntu LTS version. Your system is probably broken because Zentyal uses the ubuntu packages provided by the Ubuntu host version and Zentyal 6.2 isn't prepared to run on Focal but on Bionics.

The next Zentyal version, which should be quickly released,  will run on Ubuntu Focal, but it doesn't change your situation. Your system is broken.

I'm sorry but, IMHO, you have to make a fresh install of your Zentyal 6.2.

Cheers!
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

nkeseci

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #2 on: November 27, 2020, 11:51:58 am »
Thank you for your answer. It works somehow right now. I will make a fresh installation as soon as possible.  :)
Ragards,

decibel83

  • Zen Apprentice
  • *
  • Posts: 28
  • Karma: +2/-0
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #3 on: December 10, 2020, 03:16:10 pm »
The next Zentyal version, which should be quickly released,  will run on Ubuntu Focal, but it doesn't change your situation. Your system is broken.

Hi doncamilo,
is there any release date of the new Zentyal version?
We cannot stay on 18.04 for a long time.

Thank you!

doncamilo

  • Zen Samurai
  • ****
  • Posts: 478
  • Karma: +165/-1
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #4 on: December 11, 2020, 02:28:29 pm »
 :)

I don't know, but, any case, Bionic has standard support until April 2023.

It's your need for upgrading so critical or, simply,  do you want (like myself) to get your teeth into samba 4.11?  (Samba PSOs are a great improvement) ;)

Developers told ( Oct 30) that it will be released in a few weeks https://forum.zentyal.org/index.php/topic,35064.msg113882.html#msg113882

Cheers!
- Do my pigeons bother you passing over your land?
- They block the sun!

G. Guareschi., Don Camillo.,

blorente

  • Zentyal Staff
  • Zen Apprentice
  • *****
  • Posts: 21
  • Karma: +72/-0
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #5 on: December 20, 2020, 09:43:45 pm »
Hi all,

Thanks for your interest! The beta version should be available for testing next week. Will post an update here when you can download it.
Zentyal Server Lead Developer

webmaster

  • Zentyal Staff
  • Zen Apprentice
  • *****
  • Posts: 27
  • Karma: +2/-1
    • View Profile
Re: Zentyal 6.2 issue after upgrade to Ubuntu 20.04 LTS
« Reply #6 on: December 30, 2020, 02:39:42 pm »
Hello,

The beta version of Zentyal Server 7.0 (based on Ubuntu 20.04 LTS) is now available for testing. See this thread for further information:

https://forum.zentyal.org/index.php/topic,35064.msg114043/

Best regards,